Color and sound problem [ DOSBox-PURE ]

I’m having trouble with color in retroarch. The first is when I emulate windows 98 through dosbox pure

but it also exists in dosbox pure alone The game in windows 98 is called “Deadlock: Planetary Conquest” and the dos game is called “Lemmings.” The Dos game has multiple choices for graphics but none of them do any different.

Also I understand windows 98 has better sound with midi soundfonts and that I need to select them from the menu (which I did) but every time I open windows 98 it says it’s not set up properly.

Is there a page somewhere that says the correct combination of settings to get a specific sound file to work because the audio section in the options menu had a whole lot of options and I’m guessing I don’t have the correct options selected to work with midi sound font. The guide doesn’t say what options I need to select with midi, it just says " selected via the Audio > MIDI SoundFont core option" which I did. I’d show you a picture of the options I have selected with midi but that would take two pictures to show.

I think I figured out the sound issue, I was using the frontend MIDI selection instead of the actual midi file, which for me is called “weedsgm4_update.” It’s not making the “not set up correctly” message. Nevertheless there are lots of options in the audio section and it would be nice to know what options make the best sound, but I understand it probably depends on the game.

1 Like

I’m still having trouble with the described color issues in retroarch. And while I got the midi sound working my sound occasionally “stutters” I don’t know how else to describe it. Is there a way to improve sound?

Do you happen to have run-ahead enabled? Sorry I’m not too familiar with this core but it’s worth a look.

So run-ahead only causes dosbox pure to get glitchy, my mouse starts moving all over the place and it seems to slow down emulation as well.

But audio latency seems to have fixed the sound issue, thank you for that. I just still have weird color problems.

1 Like

I fixed the Lemmings game. Turns out the emulated graphics chip wasn’t set to the graphics chosen in the program at startup. The game lets me choose what kind of graphics to use but the retroarch settings didn’t match. This is what it was supposed to look like.

I still need help knowing what graphics chip I need to set my windows 98 game to. I tried experimenting with different ones and the first one I changed to immediately caused my windows 98 to complain. Now I regularly back up my windows 98 system but I still worry about crashing it with the wrong settings as I understand I can really damage the system that way and I don’t know if just backing up the img file is enough to fix that. So I’m hoping someone knows. Is it the one at the bottom of the list PCjr? Are they in order from oldest to newest? I imagine I need the newest.


Hello. You have 3 different problems.


VGA cards are natively compatible with EGA. And PURE most of the time can switch VGA-EGA-CGA adapters automatically, but sometimes not.
With some games, as well as with Hercules, PCjr, Tandy adapters, you need to select the video card manually.

Lemmins has CGA, Tandy, EGA and VGA, if you want to test them you have to select the video card before launching the game. Each one looks different.
And then the subselection; PC Compatibles, High Performance would be high detail and PS2 and AMSTRAD would be low detail.

Deadlock: Planetary Conquest

In Windows you should not change the video card, it always has to be SVGA.

Games change the resolution and color mode automatically, most of the time, in some cases not.

This is a common problem with Windows 3.1 based games.
You probably have the video set to 256 colors, you have to use 16 bit. In some cases it can be the opposite, they only work with 256 colors.

With right click on the desktop, properties and the settings tab you have it.


The MIDI configuration of the frontend is another thing.
If you want to change the core soundfont, you have to place the files in the System folder and change them in the core sound options.
But, it seems to me that Windows 98 is not compatible with the core option to change the sound source. Windows has its own sound interface SB-16.

That worked! The last problem I had has been solved. I kept the retroarch video settings and instead changed the color settings from 256 (which the game recommended) to “High color [16 bit]” and never had color problems in the game.

1 Like

Yes, the game says it is compatible with 256, but this is an old known bug, and sometimes it is the other way around.
WinG (Windows 3.x) is not fully compatible with DirectX (Windows 9x).