Controller not working in retroarch interface

Hi, I have used Retroarch since before 1.3.4, but took a break from emulating for a while to play modern games. Anyway, I just updated to 1.7.0, and the controller works for a while and then just stops responding. After that no matter how many times I disconnect/ reconnect the controller, it won’t respond until I restart the computer. I have a DS4 connected via Bluetooth, and while this is happening, it works fine in other games/ programs. I’ve tried connecting the controller before and after staring retroarch, makes no difference. I’ve always had this problem with the other versions a couple years ago, but not as bad as now. Thanks for any suggestions.

You can try changing your gamepad driver in settings > driver to ‘raw’ or ‘dinput’ instead of xinput and see if that helps.

Well, tonight I tried switching the joypad driver from xinput to dinput. The gamepad immediately started to respond, correctly in the retroarch menu, and not so correctly in- game. The analog stick up/ down were switched in mupen64plus, and start and select were switched in all the NES cores I tried. But so far it is a step forward.

1 Like

Any idea why the buttons were switched when using dinput? I can try remapping per core but that just seems like a bandaid-on-a-bullet-wound situation. There has to be a reason why it’s doing that in the first place.

Sometimes pads act differently with one driver or the other. Is it an autoconfigured pad? If it’s manually mapped (that is, through settings > input > p1 input binds), you can just go re-map it once and be done. If it’s autoconfigured, you can go modify the autoconfig profile for it to match.

I’ve had problems like this before and it’s always because of Retroarch choosing what it thinks is a controller over the one you’re using. The first thing I would do is check your devices. Some programs like one of my favorites, Touchmote emulates an XBOX 360 controller. All of the sudden I found that my controller would not work in Retroarch after recently using Touchmote. Touchmote is supposed to dump any connections to any Wiimotes and shut down the emulated XBOX 360 controller driver when I tell it to. Well it didn’t, and the driver was still active causing Retroarch to choose that 360 driver Instead of my Logitech controller. I could get it to work if I switch the controller from X to direct input, but then my XBOX One controller would still not work and I wanted to use both controllers. I had to reboot to get rid of the emulated XBOX 360 controller from Touchmote to go away and now all of my controller work like they should. You may not have the same situation as mine, but pay attention to what Retroarch says while it’s connecting your controllers when it starts up. Of you have only one controller hooked up to your computer and Retroarch is reporting more than one then there’s your problem.

1 Like

Thanks, @OldsXCool for the guidance about it.

You’re welcome. Glad to be of service.

I’m sorry I haven’t responded lately, but I use DS4WINDOWS, sort of a driver for the DS4 controller for windows, which makes it look like an xbox 360 controller to the operating system. Could this be what’s causing the issue? Yes, @OldsXCool, and everyone else, thank you for the replies.

I have the same issue but over steam link, used to work the all of a sudden not input being passed from the steam link to Retroarch, am using a PS3 controller

I have a very similar problem. I’m using Retroarch version 1.7.0 Windows currently, and I use the PS4 control with the InputMapper program a while ago, but a few days ago the retroarch no longer recognizes the control and I can not navigate the menus. I got to delete the control of the computer and install again and it worked, but now it stopped again. The strange thing is that until recently it worked correctly.Anyone know any solution?

I would like to know if the ps4 Dual Analogue control is working on version 1.75 of Retroarch for Windows 10.

I came across this topic through GOOGLE as the most relevant to my issue and since I can’t yet start my own topics I hope it’s not minded so much if I bump this.

I’m currently having this same issue after accidentally running Retroarch while the dongle for my Logitech f710 wireless pad wasn’t currently plugged in.

I get -no- controller input on the menus OR in games (If I launch via keyboard) The controller shows up as an xinput controller when retroarch starts up, In port 0 as normal but it just refuses to actually USE it.

I’ve even deleted the CFG files to let retroarch rebuild them, Unplugged and replugged my pad dongle in. Set to xinput/dinput via the switch on the controller, Tried changing the input driver in retroach and even completely uninstalled and reinstalled retroarch but the controller just doesn’t work.

The pad itself works fine however in any other joypad supporting title I have without issues. For some reason Retroarch just completely doesn’t anymore.

Okay, I found the issue though I have no idea why it’s even an issue in the first place.

Basically I was running Retroarch as a non-steam shortcut from steam (I have friends that like to watch my gaming from time to time through that.) and the -moment- I ran the shortcut from there instead of from the desktop (As I had been doing while testing) suddenly the controller worked again. When I closed Retroarch and tried running from the desktop shortcut, Suddenly THAT started working too.

Somewhere along the line it seems like steam’s getting itself all up between the controller and Retroarch. At least if this happens for anyone else there’s a solution now, Though I’d like anyone to help me figure out WHy it’s happening.

Yeah, Steam likes to interfere with gamepads as long as it’s open. It frequently starts sending keyboard events when gamepad buttons are pressed, etc.

It should only do that if you specifically enable Steam’s controller support though. Maybe it’s enabled by default these days on new installs.

That’s what I’m thinking, Or maybe if you use steamlink it’ll enable by default? I do use that on my GPD XD Plus once in awhile so I don’t have to be in front of the pc the whole time. Either way I never really use big picture since my tv broke and I have this dinky lil’ screen so I have no idea why it would be on.

It works in desktop mode too. You can check in Steam’s settings under Controller, General Controller Settings, then unchecking support for anything that’s checked.