Cores Not Available for Ubuntu 18.10


#1

Hello, I do not have any cores available. I checked the PPA page and it does not have anything other then retroarch (and an retroarch-assets that is outdated) in the cosmic branch. Will the cores and updated assetsand other packages be added anytime. I tried using the bionic branch but ran into issues. I have used retroarch for years, I am aware that I am able to change the directory to user writable nad just use online updater, but I have always apprciated the ppa having it all


Cores not downloading to the correct place using APT?
#2

I don’t have any plans to update the core packages at this time, no. From now on, just use the online updater to fetch our buildbot cores.


#3

Why the change? Can you recomplile it to use everything from the home directory so that the defaults can be stable


#4

It was a burden making new recipes for each core and keeping them all functional. Sergio-br2 had been maintaining all of the packages, but since he’s left we decided to just make the PPA builds act like self-compiled builds.

Yes, I can move the default locations to look within the home directory.

So the assets package is outdated, you say? I’m surprised at that, since it’s building daily and seems to be pulling from the retroarch-assets git repo…


#5

To update the cores on a usr/ directory that is currently default to, you have to open the terminal and type “sudo retroarch” to run Retroarch as admin to update the cores from online updater.


#6

that can cause permissions hell with other files, though, so we don’t really recommend that.


#7

I agree it is probably better and brings Ubuntu/Linux inline with other platforms, as for the assets perhaps it’s updated, but PPA says it’s 1.7.5 and it does but contain ozone assets. (The reason I updated today) Also once I changed my directory to home and updated assets it seems even some XMB assets got updated also


#8

I would also need to have the core infos updated to use new cores. I was using stable repository and then switched to testing to get Mupen64plus-next with core info included.


#9

Alright, I pushed up some changes to the recipe to look in default locations for cores, info and configs. The testing repo should have it soon-ish, so if you guys can test and report any issues, I’d appreciate it :slight_smile:


#10

So assets, cord, core info, is that all that would be to have defaultlt directory changed? Or are there other things also?


#11

Will do I’ll move to testing tonight and give it a try


#12

There are some other things, like video and audio filters, that are still looking in strange places, but that’s necessary because the RetroArch deb package isn’t allowed to write to user directories. AFAIK, everything else was handled by other packages, so we will no longer expect those packages to be present.


#13

I know this is a different topic, and if your prefer I’ll start it as such, but I was curious, has the way retroarch reads/saves configs changed in the last maybe year or so? I have a script that edits retroarch.cfg and adds my personal 8 or 9 lines to the config at the top because as I understand it the first value is the ones that is used and takes precidence over anything after. as far as I remember, the config would stay in the same order as my few edits where on top, but now it seems to read it, then when it rewrites it it gets reformated. An I crazy thinking it used to save it with the save order/, formatting


#14

I believe it puts them in alphabetical order now, yes.


#15

Not up yet but when it arrives ill let you know how it goes for me


#16

Hi!

I believe retroarch-assets should be removed as a dependency of retroarch, since now by default it is not being used.


#17

I can confirm that at least the little testing seem to have worked well so far. I just ran a new vanilla install, installed a few cores and assets. Tested both XMB, and ozone. Did not look at info yet. But so far so good


#18

I can also confirm that with clean installing, the directory is in the right place. The info is also in a different directory too, so I was able to install and update them. However, I tried updating the shaders, but I couldn’t see it. Tried cg, glsl, and slang packages.


#19

Thanks Hunterk, I apprciate the fast changes and taking input. I think that this will actually be really nice it makes everything a little more portable (and clonable) I have multiple boxes hooked up, some are retropie but most are just retroarch so it will be nice to have the configs a bit easier to move (again I wrote a script but it then needed sudo and was kind of a pain with permissions…im not the greatest script writer so it took me a while to make it fullproof. )

Anyway I have never actually used shaders but I can say that they atleast seem to have downloaded successfully.


#20

Thanks for testing :slight_smile:

I’m hoping to add a patch for the welcome message to tell people to use the online updater to download everything on their first run.