DeSmuMe crashes when clicking mouse for touch screen input

I’ve used Retroarch and most of the cores before, so I’m fairly familiar with them (and with how finicky they can be), but just recently I built a new pc and started setting it up there. Most things have gone swimmingly, some not so much (issues with Dolphin, LRPS2, Citra—the newer generations, but no big, I’ll get those working separately). DeSmuMe worked great however, far better than I expected, and after getting it set up and testing things for a half hour or so, I went on to the next thing. That was one, maybe two days ago.

This morning I found a few more roms I wanted to test out, so I opened up Retroarch, and they worked just fine. That is, they worked until I needed to give touch screen input. The instant I clicked the mouse, the whole frontend crashed. Okay, so I tried it again—same result. Tried another game to see if it was that or the core, and the second game ran flawlessly…until I clicked the mouse and it crashed. Tested another game that doesn’t need touch input at all, and that also worked until the moment I clicked it. Testing the first game that I tried days ago also crashed it now.

After that I tried both Retroarch melonDS and stand-alone DeSmuMe, and both of those worked fine. Tried the DeSmuMe core again, and crashed again. I hadn’t changed any core options, and also no general options besides switching aspect ratio from 4:3 to Core Provided (if curious, I also tested this both ways to be thorough, and both ways crashed). I moved all the config files out of their folders temporarily to simulate the fresh start I had a couple days ago, and it still crashed.

To be fair, I could just use the standalone emulator (the main two features I want are just full screen and mouse sensitivity settings, and the melonDS core lacks the latter. I’m assuming the standalone DeSmuMe has mouse settings), but I’m really itching to figure out why this would work one day and not the next without changing anything. I know I’ve been rambling a bit though so I’ll stop here, and thank you for any help!

We would need to see a log of it crashing to even guess what’s going wrong:

there are a few ways to get a log, but the easiest is to go to settings > log and set both logging verbosities to DEBUG and ‘log to file’ to ON. Do whatever it takes to reproduce the offending behavior and then close RetroArch (if needed). It will then create a log file in your ‘log’ directory, which you can open in a text editor. If you want us to take a look at it, copy/paste the log contents somewhere like and then post a link to it here (this is more convenient for people than having to download it and open it in our own text editors)

There have not been any significant commits to that core in some time, so I don’t think anything has broken it on our end, but definitely since May. Are you sure you used the touchscreen when you first tried it and it was working? If so, perhaps it’s something outside of RetroArch?

I’m quite sure I tested the mouse input before setting it aside and moving on. I used the mouse to enter my name and press interface buttons within the game. As for logs:

It was the “Use external BIOS” setting. I must have accidentally turned it on when I was fiddling around looking for something else.

Incidentally, does that option kill the emulator for anyone else, or is it just me?

1 Like