Dolphin - analog triggers don't work

Hi guys!

I run Retroarch on Windows 10. I have a Gamecube controller hooked up to a Retropad32 (a retro controller adapter that emulates an xInput controller). When I test it in joy.cpl, I can see the L and R triggers make the z-axis move gradually up and down.

In the “Inputs”-menu in Retroarch I’ve chosen “RetroPad with analog”, and mapped the L and R triggers on the GC-controller (= xInput device) to the L2 and R2 triggers. They are called 4+ and 5+ there, not z-axis. The shoulder buttons are called 4 and 5.

I open the Dolphin core and go to the “Controls” menu. I’ve left the Device Type on “RetroPad with analog”. It looks like this:

As you can see, all the buttons on the “RetroPad with analog” are connected to —. I press enter on one of them, hoping to be able to connect it to a GC button in Dolphin, but none show up:

I have to change the device type to just “RetroPad” (or “None”), and then the GC buttons show up. They are still there if I switch the device type back to “RetroPad with analog”, but the fact that they didn’t show up in the first place makes me think something was wrong…

Anyway, with the device type back to “RetroPad with analog” I connect the L2 and R2 trigger buttons (+4 and +5) to L and R in Dolphin. There are only L, R and Z to chose from, no L+ or R+ or anything like that:

With this setup the L and R triggers work like digital buttons, activating when pressed more than 50%, and giving the same result as pressing the L and R triggers all the way down would give (for instance, Mario can just stand still and spray water in Super Mario Sunshine, not run and spray gradually).

I’ve tried searching for clues, but all posts about something similar seem to be from like 2017, and people back then said the Dolhin core didn’t support analog triggers. Now, however, it seems like they’re supposed to work, Youtubers demonstrating the core just skip the process of button configuration, claiming it just works.

I can’t for the life of me figure out what’s wrong… please help me! :exploding_head:

PS: been trying to post my configs, but can’t find an attach-button, and when posting them as replies the forum says the post is too long…


It depends of your core version, analog triggers used to work but not anymore since the core was recently updated. There’s a fix waiting on Github :

Ah, thank you!

I’ll just wait then, no worries. A huge thank you to everyone working on the Dolphin-core, I think it’s amazing what you guys are able to do.