Dolphin core crashes when I boot a game!

I am using the latest RetroArch ( 1.6.3 ) with latest Dolphin core and I have tried Zelda Wind Waker and Mario Sunshine and when I load them it crashes! The standalone version of Dolphin works perfectly fine! I have tried it on two laptops and it doesn’t seem to work on either of them!

Can’t really tell much without a log.

Oh yeah, here is a log:

Wait… how do I add a log?

launch RetroArch from a command line with --menu --verbose --log-file log.txt and then do whatever you need to do to reproduce the crash. Assuming you’re on Windows, open your RetroArch directory and shift+right-click somewhere in there and choose ‘open command window here…’ Then, from the the console window, type:

retroarch_debug.exe --menu --verbose --log-file log.txt

RetroArch will open in its own window, where you can do whatever you need to cause the crash. Once it crashes, open the new log.txt file in a text editor and copy/paste the contents somewhere like and then post a link to the log here.


I don’t see any crash in there, or even any loading of anything at all.

Really? I just opened RetroArch and then dragged the game in the window. Then the window is white and then it is not responding! What should I do next? Record the process?

Do the log thing, but instead of drag-and-drop, go to load core and load the core and then go to load content and load the content.


Much better. It’s still not showing any errors but I can at least see it loading the game now.

The next thing to try is moving your retroarch.cfg somewhere else and trying to launch with a clean config. The only option you need for dolphin is settings > core > hw shared context ON, but you won’t be able to see until you go to settings > user interface > show advanced options ON.

It worked, thanks a lot!


got the same problem with a mac, already enable hardware shared context

same problem on a mac, already enabled hardware shared context

error log

I don’t think Macs support a high enough OpenGL in their drivers for Dolphin-libretro or Citra-libretro (or beetle-psx-hw, for that matter).

How can that be when Dolphin runs fine when installing it outside of retroarch?

Because Libretro isn’t a launcher. All cores are specifically ported to run on Libretro and nothing else, meaning the Libretro core isn’t the same as standalone.

1 Like

This is happening to me and i am on mac what do i do?

I have been trying to troubleshoot why Eternal Darkness crashes. I did manage to get it to load the very first screen, but it freezes immediately after.

This works perfectly with RetroArch on every other Rom that I have.
Eternal Darkness does work fine with Dolphin stand-alone. I copied the .ini from RetroArch file directly to Dolphin, still ran perfectly fine on Dolphin Stand-alone. I enabled Hardware Context Sharing, does not fix anything.

Okay so I fixed it and here is what I did. There are missing files from the dolphin emulator in retroarch, which makes several games not work. Also if there is a mismatch between the .ini file and RetroArch, it will not load at all.

  1. Download Dolphin-64 Stand-Alone from there website:

  2. Extract the Sys folder from the 7z file and put it at %appdata%/retroarch/saves/

  3. Rename the folder to User (or if you already have a User folder, copy the contents of Sys to User)

  4. Open up the dolphin.ini file which should be at %appdata%/retroarch/saves/User/Config/

    Hint: If you do not have this file, you need to download the Sys folder from RetroArch using the content downloader. It will put this at \RetroArch\system, take all the contents for this and put them in our %appdata%/retroarch/saves/User/ folder

  5. Find GFXbackend in the dolphin.ini document.

    For OpenGL: Make sure it equals OGL then go to RetroArch and set the driver to “gl”.

    For DirectX11: Make sure it equals D3D then go to Retroarch and set the driver to “d3d11”


I hope this was helpful for someone else, this was driving me crazy for days.

Sir, i have a problem, i’m missing the dolphin.ini file, it isn’t in my “retroarch/saves/User/Config/”

So, i did what you say, download the Sys folder from the content downloader, then, i went to “RetroArch/System/” but it seems that the folder it’s empty.

i don’t know if i’m missing something, the Retroarch downloader have finished downloading and extracting “” but at the same time, does not?