Dolphin crashing (Wii)

The RetroArch crashes when I try to load Mario Kart Wii (iso or gcz).

Windows 10 Pro 64 bits, RetroArch 1.6.7 and Dolphin 0.01.

How could I fix it?


We can’t really tell anything without a log.

Do any gamecube/wii games launch for you? Make sure you have rewind turned OFF.

I thought the Dolphin core didn’t support Wii games yet?

It can load them (sometimes), it’s just doesn’t support wiimotes, so a lot of games just don’t work.

1 Like

Where the log is saved?

Where can I see the rewind option?

Mario Kart Double Dash works.

I don’t have other Wii game.


As the man himself says:


‘retroarch-debug.exe’ is not recognized as an internal command or external, an operable program or a batch file.


Edit: ‘retroarch_debug.exe’



Hmm, that looks okay. I don’t see any errors or anything…

Thanks for your attention.

I was having this issue, and found a couple forum posts about it, but no answers were helpful. What fixed it for me was disabling the run ahead feature that I had enabled for SNES.

The Dolphin core also crashed when trying to boot up Eternal Darkness

So having scrounged Reddit, Libretro, Youtube comment sections, and basically anywhere else I could think to check, I’ve noticed that this, or at least some variation of this, is a pretty common issue, most cases being resolved with the dolphin Sys file being inserted into the C:\retroarch-win64 system folder in a dolphin-emu folder, but then digging deeper I found that some who still weren’t successful had to make sure rewind was disabled. I found a Reddit article that best summarized what I was experiencing (here: [] ) that ended with the user with the furthest prevailing issues being instructed to try having [Allow cores to switch the video driver] turned off, and having [Hardware shared context] turned on, but that’s about as far as I could get. Needless to say I’ve followed all the steps and am still stuck. when in full screen, I boot up the rom and core and get black then a crash, in windowed, it’s the same but white. I’ve got the logs here (frontend and core both set to level to for conciseness):

[INFO] === Build ======================================= [INFO] CPU Model Name: Intel® Core™ i7-1065G7 CPU @ 1.30GHz [INFO] Capabilities: MMX MMXEXT SSE SSE2 SSE3 SSSE3 SSE4 SSE4.2 AES AVX AVX2 [INFO] Built: Sep 19 2021 [INFO] Version: 1.9.10 [INFO] Git: ebe0d89d [INFO] ================================================= [ERROR] [Environ]: SET_HW_RENDER: Dynamic verify HW context failed. [WARN] [GL]: Stock GLSL shaders will be used. [libretro WARN] 54:05:528 VideoBackends\OGL\Render.cpp:763 W[Video]: Missing OGL Extensions: PinnedMemory [libretro WARN] 54:05:717 VideoCommon\AsyncShaderCompiler.cpp:125 W[Video]: Failed to initialize shader compiler worker thread. [libretro WARN] 54:05:718 VideoCommon\AsyncShaderCompiler.cpp:125 W[Video]: Failed to initialize shader compiler worker thread.

And a screenshot of my settings attached, correctly? I think?

While I have no Idea what those warnings mean, I have noticed that my advanced options core settings do not save post-crash (though my other settings that aren’t hidden when [show advanced options] is off have stuck around, like my hotkeys and fast-forward/slow down intervals for example), but I checked back a couple times before running and they seem to stay at least until I finally run the ROM (or… technically WAD to be exact). If those settings aren’t recovered once I reopen Retroarch, mayhaps they are reverting right once I run the game? That’s my theory. I’m not new to emulation by any means but I am new to RA and have also never had to obtain/analyze changelogs before (I’ve just always found a solution eventually, but I’ve definitely faced weirder issues in my 6 or 7 years of emulation), so I could be missing something glaringly obvious. I also am not sure how to make my own post on Libretro forums (no excuse for this one, I’m just new to the platform and honestly wasn’t really looking beyond “where’s the ‘make a post’ button?”), so I’m piggybacking off of your post. If anyone can shed some light on the subject for me or help me decipher these log warnings, I would be so eternally grateful.

Have you tried using a different video driver? glcore, vulkan or d3d11?

If it is crashing and not saving settings, you in may have to do get crafty. Run a GameCube ROM, set your desired settings for the Wii, save a content directory config, and manually rename it to your Wii directory.

Worth a try.:grin:

1 Like