Dolphin freezes randomly during any game

I’ve installed Retroarch onto a Ubuntu 18.04 machine. It runs and operates finely, except for when I try to play any game using Dolphin. The game plays with good performance until it freezes entirely along with RA. Sometimes it will freeze 15 minutes into the game. Other times it will freeze at the menu screen. It’s very odd. I’ve setup the system folder, and the information page confirms that it’s recognized. I’ve also turned on Hardware Shared Context. In addition to that I’ve tried toggling numerous settings/drivers on and off to see if they made a difference, but the freezing remains constant (although I’d be willing to retry some if anyone has specific recommendations).

Intel i3 8100 AMD Radeon HD 7870

I’ve also parsed through the log file and don’t see any errors/warning that (to me) would correlate with what’s going on, but I’ll post an output in a bit.

log output… I’m nearly positive that nothing is logged upon the crash/freeze.

Yeah, I don’t see anything untoward in that log. Could be it heat-related?

Thanks for the fast response. I highly doubt it, I’ll run some sensor the temp while it crashes this time.

All the temps look good before, after and during the crash. Doesn’t seem to be heat related.

1 Like

Hmm, this is interesting, stumbled across this while searching Google - I run Dolphin via a RetroPie instance based off Ubuntu 18.04 too, and I’m experiencing exactly the same as you describe.

All other emulators (Dreamcast, etc) are working fine without crashes, and there are no heat issues causing this. It can happen straight off a cold boot.

My machine is a Core i5-4590T, 8gb RAM, Intel HD Graphics HD4600 integrated. I am using compressed GCZ files. I would suggest Soulcalibur II is a game which tends to crash before you even get past the menus. All other games I have will do this too, at some random point. I tried the original GCN file uncompressed for Soulcalibur II and this crashes also, so it isn’t a compression thing.

I’ve tried all settings as default, also I’ve tried forcing preload of textures and a-sync ubershaders. The crashing I experience is also random in that it can happen within moments of launching a game, or 10 minutes later. I am using openGL as a renderer because it seems quickest for my Intel card.

Mine will freeze to the point of having to do a hard reset on the box, the controller becomes unresponsive so I can’t do anything but reset.

I am almost certain on my last install (16.04 based but used standalone dolphin) this never happened. I will need to test standalone dolphin on this install.

If anyone has any ideas that would be helpful! Without useful logs though it’s tricky to work out how it’s viable to post an issue to GitHub at this stage.

I too have been experiencing this issue. I’ve downloaded the dolphin core thru the core updater in RetroArch. I have the dolphin-emu folder in the system folder, with the system folder set in the conf file. I’ve so far experienced this on Simpson’s Road Rage, Mario Kart, Double Dash, and Super Mario Sunshine.

I downloaded RetroArch thru the recommended package repository on Ubuntu 18.04 (but I didn’t install the libretro-* packages as I wanted to download them thru the online updater built-in). Build date Feb 6, 2019 and git version 9750719.

To anyone who discovers this thread, I ended up resolving the issue by using a different graphics card. I had complete stability using a GTX 660. I’m not sure what the issue is with the AMD card that was being used, but it was the only common denominator in the problem. Some in depth research revealed that a few other people were able to resolve this issue similarly.

1 Like