Dolphin Sys Folder missing even when its in the correct spot


#1

So I set Dolphin up and have the correct zip via the libretro guide, but when I put it in the system directory, it still says “Missing: Required: Dolphin Sys folder”

I updated the core, Checked via the config file to confirm its directed at the folder (The other BIOS files I have do read from that folder fine) and its not in any program files folder, and yet it still isn’t being picked up, and thats after looking at the link and guides over and over again.

I can still play games but the text is often messed up for games like Smash Bros Melee or Mario Sunshine, probably from that, so I have no idea what to do,or if its just a bug with the core cause Dolphin seems to be one of those “alpha” cores.


#2

Has anyone figured this one out?


#3

I have the same issue, i have the Sys folder in dolphin-emu that i downloaded in the github, in the retroarch/system. so i have retroarch/system/dolphin-emu/Sys but in informations of the core, dolphin Sys is still missing…Can someone help us? please…


#4

Same for me. I tried several other places to put the folder, but none of them work.


#5

Same here, it just doesn’t recognise the folder.


#6

Let me join the band guys.

I looked up for this problem this morning and the problem is encountered by many users apparently but no fix so far mentionned.

The folder is in the correct place, correct name, I even tried various names combination thinking the wiki was not up to date (Dolphin, Sys, System, whatever), nothing worked.

Someone mentionned to try the “Download content” tab in retroarch frontend, then “Dolphin” tab, and select “Dolphin-data.zip”. This downloads the Sys folder in “Downloads” folder in retroarch’s root directory, but once again the folder is not recognized here.

There’s definitely a conflict somewhere and either the wiki is incorrect or a bug has to be fixed about this.

EDIT: I can confirm that “Retroarch/System/dolphin-emu/Sys” is the correct location apparently and is somewhat detected by the core, but I doubt it’s 100% for some reasons.

Why I’m sure about this, I tried booting F-Zero GX without the Sys folder, the game is totally messed up, no tracks or vehicles displayed, when the folder is here, it’s working fine, but there’s a couple of visual glitches mostly with texts, minor but not present on the standalone emulator.

So, the wiki is correct, but for some reason the folder is not recognized when reading the core informations in the desktop interface, and I guess that’s why there’s minor glitches, perhaps some of the files are not properly recognized by the core ? I’m no developer so that’s just a guess, still a bit of informations that should be useful to most players trying to play games with the core.