DOSbox games


#21

Uhhh… mmhmmm

and uhhhh mhmmm not exactly sure how that quote helps, it confuses me more than anything…

PSX games work fine for me and I have the BIOS files under /storage/system, not /storage/cores, so that just adds to the confusion.

I’m sure replacing core files or adding news ones is easy peasy… I just need to know where I can get the pre-compiled (.so) copies of the latest n greatest cores… without having to compile them myself.


#22

If you follow the link, there’s a short thread where some guy is asking how to update his cores.

“Lakka is distributed as a bundle for support reasons. If you want to add additional/newer cores that aren’t in the bundle, you can download them from buildbot.libretro.com 448 and put them into the ‘cores’ directory in your user partition.”

I know how to do this and can help you with it, if you like.


#23

Yeap… got lost already, figured that be straight forward… nope

First I get to the fodler structure… and I’m assuming stable… then expand again assuming the latest (highest) number, then I get names of OS and consoles? Not sure what to do from here…

Ahhh Assets… Cores…

Uhhhh nope, this just shows everything that the Lakka UI updater shows me…

Please give me a list of compiled cores to pick from and play with lol

http://buildbot.libretro.com/nightly/linux/x86_64/2019-01-04_cores/

Got to here, but no DOSbox?! cmon already… this is starting to really annoy me

http://buildbot.libretro.com/nightly/linux/x86/latest/dosbox_libretro.so.zip

Is this ^ the latest an donly one available? I could only find it under x86


#24

I added the core mentioned above, but any attempt to use it in Lakka says failed to load core

I give up, again… gave up on the Pi now giving up on the x86…

Lakka + me + DOSbox = Epic failure

I literally can’t get it to work on anything, this sucks, correction I can get DOSbox to work on every other OS expect Lakka


#25

Woah… I decided for one last try, take your CFG settings and add it to my retro cfg file settings since it was missing…

I also edited the CPU numbers that were “0” to “1”

tried Quake which was slow like all the other games and its actually playable!

Gonna try a couple more… let’s see here, this is promising…

Yes! Doom plays smoooth! I think that was it man! Thank you soo much for helping out. Just when I was about to give up… now I might be inclinded to try on my RaspPi again…


#26

Latest SVN core can be downloaded from here -> http://buildbot.libretro.com/nightly/linux/x86_64/latest/


#27

Huh, yeah there it is… I’ll try that out too if I find other issues now with the provided core.

Again, thanks so much this issue was driving me NUTS!

Not sure if it was the CPU setting change or the settings you gave me, either way both together = an awesome running DOSbox experience! Thanks again!


#28

Well done! Honestly, DOSbox can be a bit of a pain in the ass, in RetroArch. It’s not anyone’s fault. RetroArch is just designed around running and configuring emulators for consoles. It’s worth it for those CRT shaders, though! Glad you’ve got it working. :slight_smile: I’ve actually never tried DOSbox on the Pi. All the old 8 and 16 bit consoles work well but x86 emulation might be more of a strain for the Pi. Regardless, the setup process shouldn’t be too different than on your laptop.


#29

To add a core to lakka you need to add the core binary as well as it’s .info file to the lakka cores share. You need both files.


#30

Thanks for the additional info!


#31

I got another issue I can’t seem to resolve… So I have this Joystick (X-Arcade) but it appears as a keyboard to the systems I use it on. Since it’s rather complex…

I created another thread for this, since this one was pretty much answered.