[DOSBox] Keyboard Layout ingame

I have an AZERTY keyboard. In command line when I just load and charge the core, the layout matches my inputs, no problem.

But in some games, such as Warcraft or Dune II, the layout is Qwerty. I couldn’t find a proper solution so far.

On DOSBox Standalone, you can use keymapping and load this mapping at startup, but it seems keymapping editor is not available in RetroArch. I tried to load it via a conf file but [sdl] lines are not read.

Is there a simple way of making all games recognizing the my azerty keyboard layout?

Can someone help me please?

I don’t know of any solution for this, sorry.

So far, I found one that is more DIY but is probably more convenient than mentally switching keys.

I set Retropad to Keyboard+Mouse, then I assigned buttons to keys that I needed to switch (namely, A/Q, Z/W and M/;). Then I set those keys to a Retropad in Settings> Inputs.

2 Downsides however:

  1. DOSBox still recognizes original keys so if I wanted to switch A and Q, A works as Q but Q works as A+Q. Not a big deal since few RTS games use Q as a hotkey.
  2. Game Focus prevents binding to work for some reason. So I had to use “Hotkey combo feature” not to trigger RA hotkeys all the time. I’ll go with no Game Focus, I’m not sure it’s a big problem, even if I noticed some weird behaviours when it’s off (Wolfenstein 3D moves I think).

If anyone comes up with a better solution, I’m in!

1 Like