[Download] RetroArch 1.7.6 iOS 11 (& iOS 12) ipa + extras (Updated v2)


#21

@condsin : I noticed that installing with iExplorer (and iFunbox) made the apps lose permissions to run, so i removed those from my first post…

To install on a jailbroken iPhone with OpenSSH, connect via SFTP with root/alpine as login/password, and move the .app to /Applications folder this way…

Then, connect via SSH and send the uicache command !


#22

I have Jailbreak and the iOS version is 12.1.1. I put IPA on my iPAD and I played PSX games, but the sound often gets lag. Is it because JIT does not support it?


#23

@Inbeez_Runi : You can try to go to Settings -> Video, and select “Estimated Screen Framerate”, to syncronize RetroArch to you screen’s estimated framerate, it has solved problems with audio stuttering for me in the past…

But yeah, there is no JIT support…


#24

It is too sad that JIT is not supported. I’ll give it a try as you did. Thanks!


#25

Is there a way to install the n64 core from providance?


#26

nothing about retroarch works.I’ve tried this method and everything crashes. It was working fine for few seconds with the psxrearmed core then it froze and crashed. The beetle one wouldn’t even load the game.


#27

@Justintime : These are completely different apps which use different core types, they are not compatible nor compilable for each other…

@Maaza : which method did you try ? I’m confused…

  • Do the RetroArch app launch fine ?
  • Did you try included ROMS to check your installation ?
  • What CD image format did you try for the PSX cores ?

#28

Downloaded the ipa. Worked fine for first few mins. Now it just crashes.

I tried cave story with beetle psx but it says failed to load content so I just tested it out with the nsxengine and it worked.

I tried the .bin version for suikoden and I had a suikoden zip file and just tried opening that in retroarch which then got me in game for 30 secs then froze.


#29

If you use .bin/.cue CD images, you must load the .cue file that is in the same directory of the .bin file, with the same name… Then it will work with PCSX ReARMed and Beetle PSX !

Cave Story is indeed loading only with it’s proper core, which is NXEngine…

You must know the proper core for the ROMs you’re trying to load, the easier way is to make your ROMs folders labeled with the correct system, so you don’t mix it up !


#30

Oh thank you so much! I was pulling out so much hair trying to figure this out. Also how do I transfer save files and save states from provenance to retreoarch?


#31

@Maaza : Save states don’t seem to be compatible, but most save files work fine (save your game normally before transfer)…

You can use iExplorer (or iFunBox), and find the save files in :

Provenance -> Documents -> Battery States -> (YourGameName)

Copy them first from the (YourGameName) folder, then transfer them to :

RetroArch -> Documents -> saves

If the cores use compatible save formats, it will work !

Note that your save file must have the same name as a save created by RetroArch, if you’re not sure, you can start the game first in RetroArch, and then see the actual name of the newly created save file, and it’s file extension…

For exemple, I just tried with Baldur’s Gate - Dark Alliance on GBA, I had to rename the save from “Baldur’s Gate - Dark Alliance.sav2” (from Provenance VBAM core) to “Baldur’s Gate - Dark Alliance.srm” (RetroArch mGBA core), and it worked fine !

Cheers


#32

@Weedy_Weed_Smoker you’re a lifesaver man! One last question I promise. How do I speed up the game. I’m not using any controllers, just the onscreen buttons.


#33

Anytime I try to run content I get the error ‘failed to open libretro core’. Anyone have any idea what causes this or how to fix it?


#34

@Maaza : You can try the retropad overlay (gamepads -> retropad), which has a dedicated fast forward button (and a rewind button, if you enabled rewind in the options)…

If you’re using a keyboard overlay, space is the fast forward toggle, and l is the fast forward hold button !

@Tsume : You can not use the integrated Core Updater on iOS 11 and up, you can only use the cores included in this post… I have compiled and signed them specifically for that reason !


#35

Sorry I don’t understand what you mean. Seems difficult to map a fast forward toggle since I don’t have any controllers to set it up…maybe if you can show pics on how to do it on the iPhone


#36

@Maaza : Just go to Settings (Third icon in the bottom, far right…) -> Onscreen Display -> Onscreen Overlay -> Overlay Preset

Select the retropad one (gamepads -> retropad -> retropad.cfg) and you’re good to go !


#37

I’m using those cores and I get the same error.


#38

@Tsume : Did you try the included ROMs to check your installation ? If they don’t work, there’s a problem with your installation…


#39

I have a couple of questions:

  1. Are shaders working with this version? 1.7.6 on macOS crashed whenever applying a shader.

  2. I’m currently using your 1.7.5 build. Will 1.7.6 create a separate install or will it replace 1.7.5?

Thanks.


#40

Hi @ThisMyBoomStick : Shaders are indeed working fine in this version, and I think Cydia Impactor will update over 1.7.5, if not, it will just throw an error saying the app is already installed or something, so you’re safe to try it…

If you’re jailbroken, just replace the app with the new version and it will keep everything too !

I always use the “com.libretro.RetroArch” bundle identifier for the versions I post, so it will always be considered an update if you already used one of my versions…