[Download] RetroArch 1.7.6 iOS 11 (& iOS 12) ipa + extras (Updated v2)


#1

RetroArch 1.7.6 for iOS 11 and above ! (Updated v2)

Including the working cores and all the required files to not boot to a black screen or a crash (because of a missing BIOS file)… :smile:


RetroArch 1.7.6 (iOS 11 & iOS 12) Update v2 : SEGA Saturn working !

I couldn’t compile the latest versions of desmume, easyrpg, gme, lutro, mame2003 and picodrive, so older ones were used in this case…


Install :

To install on a non-jailbroken device, use Cydia Impactor (http://www.cydiaimpactor.com), you may have to re-install the .ipa every week if using a free account, or every year if using a paid developer account…

To install on a jailbroken device, just unzip the “.ipa” file (rename to “.zip”), and install to “/Applications” via SFTP or Filza — then type “uicache” via SSH…

ROMs :

You can use an app like iFunBox or iExplorer to add ROMs to the app (Or Filza if you’re jailbroken)…

I’ve included the ROMs for Cave Story (NXEngine), DOOM (PrBoom), Out Run (Cannonball), Palm OS (Mu), and Rick Dangerous (xrick) inside the “ROMs” folder, you can use that folder as the Start folder, and add or remove contents to it directly…

Optional Cores Install :

To install the optional cores inside the app just using Cydia Impactor, you can unzip the ipa (rename it to .zip), inside the “.app” is a “modules” folder, just add the cores to this folder…

After that just make a zip of “Payload” and “BundleMetadata.plist” with your cores included, and rename it “RetroArch 1.7.6.ipa” !

If you’re jailbroken, just add them via SFTP inside the “modules” folder in “RetroArch.app”…


Included cores :

Expand
  • 4do (3DO)
  • 81 (Sinclair ZX 81)
  • 2048 (2048 game)
  • bluemsx (MSX/SVI/ColecoVision/SG-1000)
  • bsnes_mercury_performance (Super NES)
  • cannonball (Out Run engine)
  • cap32 (Amstrad CPC)
  • desmume (Nintendo DS)
  • dosbox (MS-DOS)
  • easyrpg (EasyRPG/Player)
  • fbalpha (Arcade)
  • fuse (Sinclair ZX Spectrum)
  • gambatte (Game Boy)
  • genesis_plus_gx (Sega 8/16 bit)
  • gme (Game Music Emu)
  • gw (Game & Watch)
  • handy (Atari Lynx)
  • hatari (Atari ST/STE/TT/Falcon)
  • lutro (lua game framework)
  • mame2003 (Arcade)
  • mednafen_ngp (NeoGeo Pocket)
  • mednafen_pcfx (PCFX)
  • mednafen_psx (Playstation)
  • mednafen_saturn (Saturn)
  • mednafen_supergrafx (PC Engine/Turbografx/CD)
  • mednafen_vb (Virtual Boy)
  • mednafen_wswan (WonderSwan)
  • mgba (Game Boy Advance)
  • mrboom (Bomberman clone)
  • mu (Palm OS)
  • nestopia (NES)
  • nxengine (Cave Story engine)
  • o2em (Odyssey 2/VideoPac)
  • pcsx_rearmed (Playstation)
  • picodrive (SEGA Mega Drive/Genesis/Master System/32x/CD)
  • pocketcdg (Karaoke player)
  • pokemini (Pokémon-Mini)
  • prboom (DOOM engine)
  • prosystem (Atari 7800)
  • px68k (SHARP X68000)
  • sameboy (Game Boy)
  • snes9x (Super NES)
  • stella (Atari 2600)
  • tgbdual (Game Boy 2 players)
  • vecx (Vectrex)
  • vice_x64 (Commodore 64)
  • vice_x128 (Commodore 128)
  • vice_xplus4 (Commodore Plus4)
  • vice_xvic (Commodore VIC-20)
  • virtualjaguar (Atari Jaguar)
  • xrick (Rick Dangerous engine)

Optional cores :

Expand
  • bsnes_mercury_accuracy (Super NES)
  • bsnes_mercury_balanced (Super NES)
  • crocods (Amstrad CPC)
  • fbalpha2012 (Arcade)
  • fceumm (NES)
  • fmsx (MSX)
  • gpsp (Game Boy Advance)
  • mednafen_gba (Game Boy Advance)
  • mednafen_lynx (Atari Lynx)
  • mednafen_pce_fast (PC Engine/Turbografx/CD)
  • melonds (Nintendo DS)
  • meteor (Game Boy Advance)
  • quicknes (NES)
  • snes9x_next (Super NES)
  • snes9x2002 (Super NES)
  • snes9x2005 (Super NES)
  • snes9x2010 (Super NES)
  • vba_next (Game Boy Advance)
  • vbam (Game Boy Advance)

Cores included have support for :

Expand

Consoles :

  • 3DO,
  • Atari 2600,
  • Atari 7800,
  • Atari Jaguar,
  • Atari Lynx,
  • Bandai WonderSwan,
  • ColecoVision,
  • Game & Watch,
  • NEC PC Engine/Turbografx/CD,
  • NEC PCFX,
  • Nintendo DS,
  • Nintendo Game Boy,
  • Nintendo Game Boy 2 players,
  • Nintendo Game Boy Advance,
  • Nintendo NES,
  • Nintendo Super NES,
  • Nintendo Virtual Boy,
  • Pokémon-Mini,
  • SEGA 32x,
  • SEGA CD,
  • SEGA Game Gear,
  • SEGA Genesis/Mega Drive,
  • SEGA Master System,
  • SEGA Saturn,
  • SEGA SG-1000/SC-3000/SF-7000,
  • Sony Playstation,
  • SNK NeoGeo Pocket,
  • Vectrex

Computers :

  • Amstrad CPC,
  • Atari ST/STE/TT/Falcon,
  • Commodore 64,
  • Commodore 128,
  • Commodore Plus4,
  • Commodore VIC-20,
  • MS-DOS,
  • MSX,
  • Odyssey 2/VideoPac,
  • Palm OS,
  • SHARP X68000,
  • Sinclair ZX 81,
  • Sinclair ZX Spectrum,
  • Spectravideo 318/328 (SVI)

Arcade :

  • FinalBurn Alpha,
  • M.A.M.E 2003

Game Engines :

  • Cave Story engine,
  • DOOM engine,
  • EasyRPG/Player,
  • lua game framework,
  • Out Run engine,
  • Rick Dangerous engine

Games :

  • 2048 game,
  • Bomberman clone

Multimedia :

  • Game Music Emu,
  • Karaoke player

Extras :

I also compiled/linked some complementary emulators, as their RetroArch core counterparts are currently broken on iOS 11 (and added some retro Mac emulators in the mix…)


Provenance 1.5b2770 (iOS 11 & iOS 12) — N64 emulator core included

Now updated to the latest version, N64 is running even smoother now…


PPSSPP 1.6.3 (iOS 11 & iOS 12) — PSP emulator

Including the latest assets, translations, and the optional extracted font from a real PSP !


YabaSanshiro (uoYabause) 1.8.1 (iOS 11 & iOS 12) — SEGA Saturn emulator

Ads removed in this version !


ScummVM 2.1.0 (iOS 11 & iOS 12) — Point & Click games engine

Included is the smart keyboard fix, the arrows on the keyboard fix, and the mt32 emulator which seems to work fine on iOS now… And a corrected icon !


iDOS 2 1.4.1 (iOS 11 & iOS 12) — PC DOS emulator

It’s a new version including fixes for the layout on the iPad Pro and iPhone X


Mini vMac 2.3 (iOS 11 & iOS 12) — Mac 68k emulator (Mac OS 1.1 - 7.5.5)


BasiliskII 10/01/2018 (iOS 11 & iOS 12) — Mac 68k emulator (Mac OS 7.0 - 8.1)

New version with a fix for iOS 12


Everything on this list is already code-signed so you don’t have to worry about signing again if you’re jailbroken… If not, Cydia Impactor will re-sign everything for you !


#2

with 1.7.5 and 1.7.6 prdoom is not running like it should all fps options are slow and stutter don’t know if the problem is retroarch or the core itself

edit: psx rearmed just crash retroarch


#3

Links updated in the first post !

Thanks to you, I could pinpoint the commit that made PCSX ReARMed crash, it was a commit from 9 days ago : https://github.com/libretro/pcsx_rearmed/commit/68effa4470e9b67b11c66f1272347b7873eaa5c6

I filed a bug, and fixed the problem on the uploaded version, by reverting only the changes made by this commit, but still having the latest version…

For PrBoom, they are trying to fix the speed issue in the latest commit : https://github.com/libretro/libretro-prboom/commit/a56ebd113c19ca6885253b0fa0bc4f8f945917b2

This is included in the version I just uploaded, but I think there is still more work required for this core to be at least on par with the original…

Cheers !


#4

so i use appdb.to to install retroarch but with the new ipa its saying retroarch.ipa is missing info.plist

also thanks to keep us updated on ios

edit: for prdoom 60fps is not smooth at all the game start to be a little smoother at 120fps maybe there something wrong with my phone ?


#5

Oh yeah, sorry about that… The app indeed contained an info.plist file, but I forgot to put the app inside it’s Payload folder ! :sweat_smile:

Link updated in the first post !

edit : On my iPad Pro 2 ios 12.1.1, PrBoom is smoother at 120fps too, 60 fps is not too bad, but a little stuttery…


#6

BIOS files are no more legal to distribute than ROM files, by the way. you’ll want to remove those before a moderator spots them!


#7

You’re correct, I have to think of an alternative…

Maybe a YouTube video for each emulator shared here with the links in the video description, or a link to a personal web page that stores all these files…

Note that I provide this service mostly for users that don’t have the knowledge that these are needed to actually run the games, and will complain that it boots to a black screen or a crash, and that I will most likely direct them to a BIOS download anyway…


#8

You can easily disable the ads in the ad-enabled version of Yaba Sanshiro, just edit the GoogleService-Info.plist DATABASE_URL to http://, IS_SIGNIN_ENABLED to false, IS_GCM_ENABLED to false and IS_ADS_ENABLED to false…

I uploaded a version with these modifications !


#9

RetroArch link updated with the latest fbalpha ! :wink:


#10

Just sideloaded with Impactor (iPhone XR on 12.1.4) everything runs perfectly. Thanks for compiling.

Has anyone worked with the Provenance dev to get Mupen64 running? I side loaded that too and was able to run rogue squadron With only a few hiccups in the sound.


#11

can i know why choose mame2003 and not mame2003-plus ?


#12

I’m not aware of any other version of MAME compilable for iOS 11 / iOS12…

I tried to compile mame2003_plus many times for iOS arm64, but even on the official pre-compiled cores, it’s not available… https://docs.libretro.com/guides/install-ios/

I would love to see a fix for it to finally compile !


#13

Hi, I tried both ways to install RetroArch (am on jailbroken iOS 11.4.1 iPad Pro 2017) but I am not able to use the app at all as it crashes on launch. What else can I try?


#14

Delete the app from /Applications then type uicache again via SSH, then you can try again via Cydia Impactor, if this doesn’t work, try the 1.7.5 version posted here with Cydia Impactor…

If any of this work, I will help you install it properly for a jailbroken device


#15

I tried all of that, unfortunately they didn’t work. Either the IPA won’t be installed at all, or it crashes


#16

What error do you get when it can’t be installed ?


#17

Strangely there is no error messages at all, just nothing shows up at all even after using the uicache command

What jailbreak are you using by the way?


#18

Now using unc0ver on iOS 12 but I used Electra on iOS 11 and it worked fine on an iPad Pro !

The uicache command can take 30s-1m but you must stay connected to SSH before the command is finished executing…


#19

to replace the buggy prdoom you could post this 64bit version of doom classic https://github.com/tomgreen66/DOOM-IOS2/tree/64bit_ios

or i just have to learn how to build stuff myself with a vm XD


#20

@QcSamuel : I just published the latest version including the new PrBoom core in the first post, including many fixes since the last time… It’s now running smoothly at any FPS !

I don’t know when it was fixed but SEGA Saturn games are now playable in this version thanks to a new update to Beetle Saturn (mednafen_saturn) !

Links updated in the first post ! :wink: