[Download] RetroArch 1.7.7 + other emulators (iOS)

iOS Emulators :

You can use my website for now until the issue with my previous post on this forum is resolved ! :wink:


iOS Emulators repo :

Or if you’re jailbroken, you can just add my repo to Cydia by clicking this link on your jailbroken device, (this link for Sileo) or by adding this source to Cydia : http://johan.margueritte.free.fr/repo


I created a buildbot too specifically for jailbroken iOS 10 & 11+, and for iOS 6 to 9 jailbroken or not ! It is already configured in my RetroArch downloads…

iOS 11+ buildbot : (64-bit)

http://johan.margueritte.free.fr/buildbot/ios-arm64

iOS 10 buildbot : (32 & 64-bit)

http://johan.margueritte.free.fr/buildbot/ios10

iOS 9 buildbot : (32-bit)

http://johan.margueritte.free.fr/buildbot/ios9

iOS 6, 7 & 8 buildbot : (32-bit)

http://johan.margueritte.free.fr/buildbot/ios


I just updated RetroArch and the cores to the latest versions, and added support for even more previous iOS versions, down to iOS 6 !

Now all tested ! If you had problems with older iOS versions, they’re most likely fixed now…

2 Likes

Any plans to compile 1.7.7? I don’t know if there are any ported improvements for iOS with this release. Thanks for doing all the work on this (and Provenance).

Just updated my website, and the Cydia/Sileo repo ! :wink:

2 Likes

Looking good - but for dosbox can we can get the SVN version please? These are features I am looking for: DOSBox-SVN features

You;d have to build with fake SDL

No, you can’t link SDL1 statically

OK thanks anyway guys - I guess with all the work put into RA and iOS anyway by yourselves using the mainline 0.74 and conf files is fine.

@Weedy_Weed_Smoker thanks for the updated N64 too - and speaking of non-RA emulators and SDL there’s an amiga one called iUAE. Even I can get it to compile and install through XCode in ~30mins, so if you’re ‘collecting’ emulators, there you go.

1 Like

So, the alpha version of Provenance you include doesn’t have N64 support, but the version of Provenance I get from builds.io does have N64 support. Tested and works and all that. :slight_smile:

Can confirm that N64 on provinance does not work on my XS Max. It works for my iPhone 6s and iPad Pro, maybe an A12 conflict? Anyway it keeps saying there is no N64 core detected, odd since it shouldn’t need one. I imported the bios file but no dice

Sorry, needs a core, was thinking bios. I looked in the core menu and Mupen64plus is missing.

Thanks for your hard work, @Weedy_Weed_Smoker, looks like the version you are distributing is missing the n64 core. :slight_smile:

Also, any tips on getting Yaba Sanshiro to work? I’ve put a “bios.bin” file for the bios that I use on my PC (and works) in the documents directory, and it’s listed in the listing, but whenever I run a .cue file (and yes, there’s an accompanying BIN file that the cue sheet references), Yaba Sanshiro just takes me to the saturn main menu and tries to play the disc like a music CD.

Also, you say above that you got the ad-free version on Yaba Sanshiro, but the version I got from your repo has ads. :slight_smile:

1 Like

@DennyThray @Thegoodstuff24 The Provenance build I am distributing indeed contains the mupen64 core, but the problem resides with Sileo, or more generally the Chimera jailbreak…

The frameworks inside Provenance (including mupen64) are supposed to be dynamically code-signed by the Realm framework, but for some reason, it doesn’t happen on the Chimera jailbreak (I tried signing all the frameworks myself, but it still isn’t enough…)

I’m very confused, I fixed RetroArch on Sileo, I fixed PPSSPP on Sileo, but I might give up supporting this version of Provenance on the Chimera jailbreak, at least for the time being, as I can’t figure out how to make the mupen64 core work…

@DennyThray Could you try your bin/cue files with the Mednafen Saturn (beetle_saturn) RetroArch core ?

uoYabause/Yaba Sanshiro has a better upscaler, but is filthy with ads, and it’s smart integration of Google for it, which enables them even if I nuked them first…

By Chimera do you mean substitute is the issue?

@Thegoodstuff24 Not really, it’s more the way Sileo installs apps, or the way Chimera deals with code signatures, permissions and entitlements

I fixed RetroArch with Sileo by injecting the “uses sandbox” entitlements to “false”, as well as using root:wheel permissions and set UID/set GID for the app executable and all the cores (frameworks/dynamic libraries) for it to be installed as root…

PPSSPP with Sileo was another problem which made the app crash when using the JIT Dynarec while installed as root with Sileo, I forgot the exact steps but there is only one app executable and no “frameworks/dynamic libraries”, and it finally worked as good as with Cydia…

Provenance I tried so many things but as soon as it is installed as root with Sileo, no matter the entitlements, permissions and signatures, it loses access to the mupen64 core, maybe because it’s not just one framework, but a group of frameworks (mupen64plus, mupen64HLE, mupen64glide plugin and mupen64RICE plugin !), as other cores work just fine…

I was able to make it work fine with Sileo, but NOT if it is installed as root (not in a sandbox, with access to the entire file system, and not saving roms and stuff to the iTunes/iCloud backup wasting precious space !)

1 Like

Too bad, it was nice utilizing trustcore, but sounds like it’s more trouble then it’s worth.

Unc0ver will be released soon for A12, so we will we if it plays better with that. I will say there is something off with the provenance IPA. Couldn’t load it with Cydia Impactor or ReProvision on any device. There’s some broken dependencies apparently. Was able to unzip it and install it manually on all pre A12 devices

@Thegoodstuff24 I uploaded an updated version of the Provenance ipa on my website, I removed all code signatures and signed it again, to fix installation errors with Cydia Impactor…

1 Like

Thanks a lot for what you do. I have a problem though: iUAE works fine, but hangs if I try to restore a game state.

Basilisk and Retroarch (installed through Cydia) work fine!

My specs: Ipad pro 12’9, iOS 11.4.1, Unc0ver 3.01

Can you help me?

Thanks

@Weedy_Weed_Smoker How do I fix the orientation for this? When I try to lock the screen on landscape the emulator automatically turns itself to portrait mode.

Doesn’t seem to work. I have 8+ but as soon I lock it the screen goes portrait. I also don’t see a video rotation option

@Maaza Yeah, you’re correct…

I just tried on an actual plus-sized device (iPhone 7+) and it seems to be impossible to lock the screen to landscape mode (and the advanced settings -> video rotation doesn’t have the desired effect)

I’m afraid you must unlock the screen rotation every time you want to use RetroArch, or modify the Info.plist located in RetroArch.app, and in “Supported interface orientations”, remove “Portrait (bottom home button)” and “Portrait (top home button)”…

You may need the already modified file if you don’t have access to a plist editor, so I uploaded a modified version for you here : https://www.mediafire.com/file/61n156o23xwb02a/Info.plist/file

If you use the .ipa version, just follow the same instructions as for adding optional cores, but just replace the Info.plist file instead !

2 Likes