[Download] RetroArch 1.7.6 iOS 11 (& iOS 12) ipa + extras (Updated v2)

Nope… Still there ! :yum:

Mupen64 is a RetroArch core for 32-bit iOS (iOS 10 and earlier), but it is available in Provenance, which is still in the list !

After updating my retroarch, I am no longer able to open the games on it. A message “failed to open the booklet core” appears when trying to open the games. In the discord the people do not pay much attention, until I got here and saw that they can help me. I downloaded the app through builds.io, after the problem I tested versions 1.7.0, 1.7.5 and 1.7.6 all give the same error.

Use in ipad 2018, ios 12.2

Can someone help me?

Excuse my ignorance, but what the hell is the “booklet” core you’re trying to load ???

What game, core, and all…

I’m trying to load the core pcsx reamer of PS1 game of yugioh forbidden memories. I also tested with GBA core. The error message is: “Failed to open core libre” and then “100%: mFi Controller configured in port # 0.”

Did you use the integrated “Core Updater” ? You cannot use cores downloaded from there…

Use only the cores already included, or the optional cores in this post… After install, you can test using the included ROMs — to check your installation…

No, I tested that way too as was the example of the friend above. But my version was not installed as in the post, yes by the builds.io … In the post I got the optional cores and added to the retroarch recently installed.

I have some doubts about the problem being ios 12.2 or that I’m not arranging the directories of retroarch correctly, what kind of folder should the kernels have?

The error you get, “Failed to load Libretro core”, is caused by not properly signing the core…

I think builds.io didn’t sign them correctly, or something… But I’m curious, can you screenshot the directories inside the RetroArch that is installed this way ? Main directory, ROMs directory if there is one, system directory…

Then you can install my version if you want, it works fine, but some people on Windows and iOS 12.2 have issues with Cydia Impactor to install it, tell me if you have problems with that too…

I tried to install your version and I could not, but I did not give importance to the communication error of cyndia and the ipad.

I will try again and if you have any mistakes, I thank you for your help.

You could try to unzip my version (rename the .ipa to .zip), then zip again the “Payload” and “BundleMetadata.plist”, and rename your zip to “RetroArch 1.7.6.ipa”…

Tell me if this works for you !

Just to restore some of your sanity Weedy Weed but I updated everything in prepapration of an Easter trip and it is all good, including mupen on provenance… thanks for keeping this alive!

P.s. also good are the additional cores using the zip/unzip

1 Like

What directory are the bios’s stored in? Also is there an actual core for Provinance that can be added to the RetroArch module folder or is it strictly another IPA?

Provenance’s cores are using a completely different system, they are not interchangeable with nor compilable for RetroArch…

The BIOSes are in the assets.zip file, in the “system” folder ! :wink:

Thanks. Just curious, does anyone ever have issues with provenance not displaying anything when a rom is loaded? More specifically, when I run a psx rom I hear it run fine but there’s no visual. Sometimes it works and sometimes it doesnt. Thoughts?

Some people on Windows and iOS 12.2 have issues with Cydia Impactor to install it, please tell me if you have issues or if it works fine in the comments (tell me what is your config too) !

It works fine on iOS 12.1.2…

So basically you build RA, you build the cores, create an IPA bundle and then they have to get it on cydia impactor?

That’s all?

Do you have to sign the stuff after building?

hey could you update the core NeoPop to fix the flicker when you go on the retroarch menu

Pretty much yeah… Anyhow, here is the actual process, using some extra steps to use my preferred bundle identifier of “com.libretro.RetroArch” :

I first download libretro-super, I compile the cores, I try to compile the cores that don’t get automatically compiled, I try to find the errors with the cores that don’t compile, I use older versions of the cores if they used to compile and can’t fix them…

Then I compile RetroArch without the cores, I change the bundle identifier to “com.libretro.RetroArch” in the info.plist, I remove the code sign folder and the mobile provisions file, I put the cores in the app, I download the latest assets, I put the demo ROMs and system files in it, and then put it in the app, create a Payload folder, put the app inside, zip it, then rename it to ipa…

I then install this ipa for signing and getting the new bundle identifier saved in the signature with Cydia Impactor on a jailbroken device, I look for the installed app by using Filza on the jailbroken device, I copy this signed version back to my computer, and then I make the ipa again with this signed version !

How do I fix the orientation for this? When I try to lock the screen on landscape the emulator automatically turns itself to portrait mode.