[Download] RetroArch 1.7.7 + other emulators (iOS)

@Thegoodstuff24 Not really, it’s more the way Sileo installs apps, or the way Chimera deals with code signatures, permissions and entitlements

I fixed RetroArch with Sileo by injecting the “uses sandbox” entitlements to “false”, as well as using root:wheel permissions and set UID/set GID for the app executable and all the cores (frameworks/dynamic libraries) for it to be installed as root…

PPSSPP with Sileo was another problem which made the app crash when using the JIT Dynarec while installed as root with Sileo, I forgot the exact steps but there is only one app executable and no “frameworks/dynamic libraries”, and it finally worked as good as with Cydia…

Provenance I tried so many things but as soon as it is installed as root with Sileo, no matter the entitlements, permissions and signatures, it loses access to the mupen64 core, maybe because it’s not just one framework, but a group of frameworks (mupen64plus, mupen64HLE, mupen64glide plugin and mupen64RICE plugin !), as other cores work just fine…

I was able to make it work fine with Sileo, but NOT if it is installed as root (not in a sandbox, with access to the entire file system, and not saving roms and stuff to the iTunes/iCloud backup wasting precious space !)

1 Like

Too bad, it was nice utilizing trustcore, but sounds like it’s more trouble then it’s worth.

Unc0ver will be released soon for A12, so we will we if it plays better with that. I will say there is something off with the provenance IPA. Couldn’t load it with Cydia Impactor or ReProvision on any device. There’s some broken dependencies apparently. Was able to unzip it and install it manually on all pre A12 devices

@Thegoodstuff24 I uploaded an updated version of the Provenance ipa on my website, I removed all code signatures and signed it again, to fix installation errors with Cydia Impactor…

1 Like

Thanks a lot for what you do. I have a problem though: iUAE works fine, but hangs if I try to restore a game state.

Basilisk and Retroarch (installed through Cydia) work fine!

My specs: Ipad pro 12’9, iOS 11.4.1, Unc0ver 3.01

Can you help me?


@Weedy_Weed_Smoker How do I fix the orientation for this? When I try to lock the screen on landscape the emulator automatically turns itself to portrait mode.

Doesn’t seem to work. I have 8+ but as soon I lock it the screen goes portrait. I also don’t see a video rotation option

@Maaza Yeah, you’re correct…

I just tried on an actual plus-sized device (iPhone 7+) and it seems to be impossible to lock the screen to landscape mode (and the advanced settings -> video rotation doesn’t have the desired effect)

I’m afraid you must unlock the screen rotation every time you want to use RetroArch, or modify the Info.plist located in RetroArch.app, and in “Supported interface orientations”, remove “Portrait (bottom home button)” and “Portrait (top home button)”…

You may need the already modified file if you don’t have access to a plist editor, so I uploaded a modified version for you here : https://www.mediafire.com/file/61n156o23xwb02a/Info.plist/file

If you use the .ipa version, just follow the same instructions as for adding optional cores, but just replace the Info.plist file instead !


Woah awesome! Thanks so much man, I’ll download it later and check it out

1 Like

Are you compiling from master? I just tried building RetroArch for my iPhone following http://docs.libretro.com/guides/install-ios/ and it looks… not great:

looks like you’re just missing the assets, which you can get from the online updater.


oh! thanks! yeah, that worked fine.

I recently discovered that the Frame Throttle -> Sync to Exact Content Framerate (G-Sync, Freesync) option works great on iOS devices, please be sure to enable it for accurate FPS all across non-60 FPS content ! :wink:

Edit : Updated RetroArch and the cores, and created a buildbot for each supported version ! (iOS 10+ must be jailbroken to use the buildbot…)

Included the latest MAME version for 64-bit devices thanks to @harakari2’s hard work ! You can thank him for that…

Links updated in the first post !


Work on Nintendo Switch with SX OS?

@Alexmini The Switch OS is a completely different platform, I didn’t even try to hack mine, but I think there is great progress on it with the homebrew community !

You can check the Nintendo consoles part of the forum if you want more informations…

Can you ever compile tvOS version of RetroArch? 1.7.7 was working good on tvOS 12.3 and continue working on iOS 13, but on tvOS 13 give “failed to open libretro core”. Have you any thoughts what to do?

Yes I can. I use modules from your 1.7.7 ipa and build myself with libretro-super. Result: good working on iOS 13 and “failed to open libretro core” on tvOS 13. I can’t downgrade tvOS 13 to 12.3 because I have ATV 4K. Provenance working good on tvOS 13, RetroArch can’t start any core.

All cores working in Xcode (run after building). But after stop Xcode running application give the same error “failed to open libretro core”. I signed cores before running Xcode, changed permissions - nothing helps. What could be the reason?

Ok. I send two zip files: Xcode archive and ipa Release version selected for testing purposes.

@xdccrlz Ok, can you test this IPA ? http://www.mediafire.com/file/fp2l7p5xkz1qq6b/RetroArchTV_1.7.7.ipa/file

(I think we can delete the back and forth messages to avoid cluttering this topic…) :smile:

The same result: failed to open libretro core(