Fast Forward causes crash in Beetle_PSX_HW when using Vulkan

I was going through all my cores to set new shader presets, and am finding that Beetle_PSX_HW is crashing retroarch whenever I try to fast forward.

I assumed this was some setting I changed, so I’ve done a million different combinations of video settings in output & synchronization. I reset my core options to default. I tried it in windows and fullscreen and windowed fullscreen… nothing fixes it.

I even made a log, but it’s such a hard crash it doesn’t show anything:

[INFO] RetroArch 1.14.0 (Git 7a2c6e9)
[INFO] === Build =======================================
[INFO] CPU Model Name: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
[INFO] Built: Feb 17 2023
[INFO] Version: 1.14.0
[INFO] Git: 7a2c6e9
[INFO] =================================================
[INFO] [Input]: Found input driver: "dinput".
[INFO] [Core]: Version of libretro API: 1, Compiled against API: 1
[INFO] [Audio]: Set audio input rate to: 48000.00 Hz.
[INFO] [Video]: Set video size to: fullscreen.
[INFO] [Vulkan]: Vulkan dynamic library loaded.
[INFO] [Vulkan]: Found vulkan context: "vk_w".
[INFO] [Vulkan]: Detecting screen resolution: 2560x1440.
[INFO] [Vulkan]: Found GPU at index 0: "Radeon RX 590 Series".
[INFO] [Vulkan]: Using GPU index 0.
[INFO] [Vulkan]: Using GPU: "Radeon RX 590 Series".
[INFO] [Vulkan]: Queue family 0 supports 1 sub-queues.
[INFO] [Vulkan]: Got 3 swapchain images.
[INFO] [Vulkan]: Using resolution 2560x1440.
[INFO] [Vulkan]: Using RGB565 format.
[INFO] [Vulkan]: Loading stock shader.
[INFO] [XInput]: Found XInput v1.4.
[INFO] [Joypad]: Found joypad driver: "xinput".
[INFO] [Video]: Found display server: "win32".
[INFO] [XAudio2]: Requesting 64 ms latency, using 64 ms latency.
[INFO] [Display]: Found display driver: "vulkan".
[INFO] [Playlist]: Loading history file: "X:\Emulators\RetroArch\".
[INFO] [Playlist]: Loading history file: "X:\Emulators\RetroArch\".
[INFO] [Playlist]: Loading history file: "X:\Emulators\RetroArch\".
[INFO] [Playlist]: Loading history file: "X:\Emulators\RetroArch\".
[INFO] [Playlist]: Loading favorites file: "X:\Emulators\RetroArch\".
[INFO] [Core]: Using content: "X:\Games\Sony PlayStation\Street Sk8er (USA).chd".
[INFO] [Core]: Content ran for a total of: 00 hours, 00 minutes, 00 seconds.
[INFO] [Core]: Unloading core..
[INFO] [Core]: Unloading core symbols..
[INFO] [Video]: Does not have enough samples for monitor refresh rate estimation. Requires to run for at least 4096 frames.

I tried updating to the latest nightly, updating cores, core info, and assets just to be fully up to speed, but that didn’t matter either.

I’ve never seen this behavior, and I didn’t find anything via searching the forums.

Any ideas?

EDIT: I discovered this is ONLY happening in Vulkan, but it didn’t use to be the case. Switching to OpenGL Allows FF to work ok. I’d much rather use Vulkan though if I can somehow identify what’s causing the crash.

Did you try without the Shaders?

Tried disabling Frame Throttle > Fast-Forward Frameskip yet?

I’m not able to replicate any crashes with the same conditions, but I’ve seen it help before.

And I think that option should be forcefully disabled with Vulkan anyway since it already does frameskipping internally, so the result is not as fluid when it is doing double skipping.

1 Like

Yeah, just tried it now. Even with shaders completely disabled the same thing happens. Screen goes black and RetroArch freezes and crashes.

THAT DID IT. This is a newer setting right, I don’t remember this one.

Also didn’t help I have most the settings menus hidden as I normally never need them, so I didn’t think to play around in the Frame Throttle menu.

Either way THANK YOU!

1 Like