Final Burn Neo control problem

In the FBNeo core, when i press A on the retropad, the core thinks i’m pressing 3 buttons at the same time. I’ve confirmed this by going into the hardware dipswitch options in various games and going to the input test and pressing the button.




This makes most titles unplayable because once you’re in-game, it either doesn’t register any input at all, or it freaks out and thinks you’re pressing buttons randomly (depending on the game).

What makes this weirder is it’s only happening with my controller, the keyboard words fine.

It’s not happening in the MAME core or any others, only Finalburn Neo and only since one of the recent core updates. I’ve deleted all my config files and done a fresh install in an entirely new folder to no avail.

Hmm, I believe FBNeo just recently added support for 3xPunch and 3xKick macros. I don’t know what, if anything, they’re mapped to by default, though.

What you are pressing is the new macro buttons, those macros are mapped to L/R/L2/R2 buttons by default, not the A button, my only guess is that your controller is wrongly mapped, especially if it doesn’t happen with keyboard.

Thanks for the responses.

I’m definitely pressing A, i’ve checked the mappings. It appears to be an issue with certain controllers, coz i tried another one and it works fine. I’m baffled as to why it happens with one and not the other though, as i’ve been using that controller for a long time now and it was all working perfectly prior to the macro update. Very weird.

Obviously, pressing that “A” button also trigger the L2 or R2 button on that controller, the only reason it “worked perfectly prior to the macro update” is because those 2 buttons were doing nothing at the time. If it’s not a mapping issue then your controller is broken.

OK I will look into outright disabling the macros then. The controller is not broken as it works normally on every other retroarch core, and standalone emulators, and PC games, and my PS4.

you should be able to just go to quick menu > controls and see what the macro buttons are mapped to and, if you want to unmap them altogether, just change them to ---

If you are confident about that, then it’s wrongly mapped for some reason.