Fire-TV Stick: N64 Conker's Bad Fur Day

Hi everyone.

I have tried to run “Conker’s Bad Fur Day” on the Amazon Fire TV stick (2. Gen).

There are three cores available: 1.) Mupen 64 Plus (GLES 3) 2.) Mupen 64 Plus (with GLES2 obviously) 3.) Parallel 64.

The Mupen 64 Plus-core with GLES 3 won’t work with any game.

The other two work, but the game runs very slow with a low framerate and the sound stuttering. Also there is always a ghostly image of Conker in the lower left corner which surely doesn’t belong there.

I have also tested “Super Mario 64” which seems to run decent. And “Kirby 64: And the crystal shards” which has the same bad performance issues as Conker. I always tried both, the NTSC and PAL versions, with no remarkable difference.

Is it possible to run Conker on a Fire TV-stick? Or is the Fire-TV-stick’s hardware just too weak? I have Retroarch 1.7.0 installed by the way.

Greetings, Christian.

The N64 is one of the most demanding machines to emulate and even my PC with i5 processor have a hard time with more advanced games like Conker. I am pretty sure that your Android device simply do not have the power required to run it as the device is meant mostly for watching video and not really 3D gaming.


I was afraid someone would say that. I’m still impressed that Super Mario 64 works. Thanks for your reply.

What Plugin do you use with ParaLLEl? AFAIK, it supports Angrylion and Glide (the old plugin, not the newer GlideN64). Angrylion won’t run at any good speed with this game, no matter the system. Have you tried running the game with ParaLLEl+Glide maybe?

1 Like

Make sure rewind is not enabled on any of the N64 cores and that the resolution setting is (unfortunately due to high requirements) set to 320x240 for the best performance.

If it works,I recommend giving Mupen64Plus FZ Edition a try if Gen 2 Fire TV Sticks have a new enough Android version. My 1st gen Fire TV box won’t let me use Mupen64Plus FZ Edition because even the latest pre-rooted update that matches the latest normal update still lacks a new enough android version.

When I go to “Quick-Menu => Options => GFX Plugin” it is set to “Auto”. When I toggle through the options there are the following available: “Auto, Glide64, gln64, rice, Angrylion, parallel”. I can change them while the game is running but I see no difference. When I close RetroArch and re-open it, everything is set back to the default settings (in this case “Auto”).

Rewind is disabled. I never use this in any emuator-core because I know that it consumes a lot of ressources.

The resolution in “Parallel 64” is default set to “640 x 480”. The resolution in “Mupen 64 Plus” is default to “320 x 240”. I can’t change that because when I change anything in the options and close and re-open RetroArch, everything is set back to the default settings. Even when I use “Save Core Overrides”.

My Fire-TV stick has Fire OS I don’t know which Android version that is.

I don’t know what “Mupen64Plus FZ Edition” is. When I go to “Load Cores…” it is not listed there.

It seems that it’s hopeless. The N64 seems to be a bit too much for the poor little Fire TV stick.

Maybe I get a real copy of this game someday. Unfortunately it sells used for around 200 Euros on Amazon. I have to win the lottery first, I think.

Mupen64Plus FZ Edition is a stand-alone app you would be able to find normally in Google Play on non-Amazon devices. In the case of Amazon devices,you will have to side-load it (if capable on newer OS versions in at least gen 2 devices) which probably takes more than what a FireTV box needs.

Back in the day I used ADB directly on the device via localhost with a USB keyboard to initially transfer what I needed in order to more easily access apk files of legitimately free apps without further needing ADB because a web browser allows downloading the apk files directly. Nowadays there is apkpure which is what I can confirm safe for the most part for the legit free apps and I still use today on my new device Shield TV Pro when incompatible apps happens in order to access stuff like Discord without needing to power on my laptop.

As for Conker,the Rare Replay version is plaqued with Glide64 style bugs (wonder if they in fact used Glide64) and lack of depth rendering effects like the sun corona altogether not appearing. Then the Live and Reloaded version is hampered with extra censorship and console exclusivity unless they brought it back to the next-gen Xbox stuff.

1 Like

Choose “Glide64” as the plugin and then go to the first line where you can save these options for that specific game. Save it and the next time you load Conker, it will use Glide64.

1 Like

What is the “Rare Replay” version?

I have loaded the game with Parallel 64 and set the GFX Plugin to “Glide64” and the Resolution to “320 x 240”. Then I used the first line in the menu which says “save game-options file”. After quitting and re-opening the content with Parallel, everything was set back to the defaults. (Auto, 640 x 480).

It seems that the N64 cores are not really compatible to my device. By the way: I have absolutely no problems with other cores. I usually emulate the NES, Sega Master System, SNES, MD and PC-Engine. No problems there, the games run like on an original machine with perfect framerate and very smooth scrolling.

I recently read that the Parallel core has to use 640 x 480 in order to work properly,apparently.

The Rare Replay version is the one included on the game collection of the same name for Xbox One.

That version is essentially in an N64 emulator on the console with broken effects but in an HD resolution (yet no widescreen/has decorative art replacing black borders) and apparently has smoothed out 30fps instead of bad frame-rates. The lost rendering accuracy was likely due to bad performance of what very likely appears to be Glide64 being used on whatever emulator is being utilized to make it run,as it has the shaking texture bug that Glide64 is known for,very easily seen on the chapter,Buga the Knut in the floor textures.

Guess you can’t judge it too much since it takes emulation of the BattleToads (how else would you have the rewind feature on there,hence “replay?”) and other games from earlier platforms and Rare directly implemented emulation of other systems in N64 games in the past anyway. DK64 with Rare’s Jetpac game and also the unfinished ZXSpectrum emulation setup (no games built in) found inside of GoldenEye.

1 Like

Ah, all right. I don’t have an X-Box One. I have a Nintendo 64 and an original X-Box. I’ll go looking for it on one of these systems. I guess a copy of “Live & Reloaded” is a bit cheaper than the original N64 cartridge. I hope the censorship is not too bad. Anyways, thanks for the informations.

Do you have the option to “load overrides automatically” enabled?

I assume it’s disabled, which is why you get your options defaulted after you saved them?

1 Like

When I load the content, the line at the bottom of the screen says something like “Loaded game overrides succesfully” so I guess its enabled. I also noticed when I choose “Close Content” from the quick menu, the program crashes and I end up in the Android start screen (this is not normal, the interface is intended to stay open).

In other cores there are no problems like this. For example in an NES core when I go to options and change something like “Crop Overscan” there’s no need to save this explicitly. Its automatically saved when the program is closed properly.

My guess is, that the Fire TV sticks Android version is too old or its lacking some drivers which the N64 cores need.

If you change some RetroArch options for a specific game, let’s say Conker, the override will be a .cfg file called “Conker’s Bad Fur Day (USA).cfg” in config/ParaLLEl N64.

The plugin options in parallel, are “Core options” though. These go to a different file. If you change them and save them for this specific game there will be a .opt file called “Conker’s Bad Fur Day (USA).opt” in the same folder.

Check if this .opt file exists. Open it with notepad and see what’s been saved. There’s something wrong if your core options get to default even when you save them. Find the “parallel-n64-gfxplugin =” line. If it’s “auto” change it to “glide64” manually and save it. Then make the file read only and see if it loads the correct settings after that.

Edit: That’s with Windows. So i assume you have to do the same steps with whatever Android has.

1 Like

That sounds complicated. To be honest, I don’t want to experiment too much and risk that something will be damaged. I’m very happy with RetroArch like it is and I can live without N64 emulation. But thank you very much for your help. I really appreciate it.

1 Like

One long-standing issue still in RetroArch is that it sucks at saving if you run into crashes,frustrating re-configs and large game progress lost,all bc the app was too lazy to save as it won’t save without exiting crashless. Changing settings should have an option to auto save without needing an interval which would keep trying to save the settings too much when not needed due to not changing anything within the interval timer and also,there should be an ability to change core settings without opening games (N64 cores notoriusly crash with altered settings) in the core,let alone opening the core,so if crash prone settings are made,you don’t have to wipe out the changes to restore access to a core just to change it again,all that is needed is an option to edit core settings without booting the core,then it would pre-save and modify settings before going into it,so if anyone trashed the settings and its crashing every time the core is opened,you’d simply choose the edit core settings option to go restore to defaults or edit each change until you can stop the crashing. For auto saving of global settings,it should save moments after making changes to settings on a slight delay to prevent overwhelming anything,maybe after each menu navigation only when something has been changed.

An example for save files and core/global settings alike for interval issues is,what if you exit before it has a chance to save your latest changes? You will end up losing progress even though you enabled saving intervals. This has the same cause for concern on a few stand-alone emulators that save on intervals instead of finding out when the game is being saved manually while in-game,so if you had saved in-game then exit too quickly,its like you never even saved that time,meaning you just lost a lucky spawn you first grinded for a long while,then recovered HP/MP and saved and started grinding again with the 1st hit being a rare encounter and you swiftly succeeded on it,saved the game,then (too quickly) exited for the session before it had the chance to save your lucky encounter/spawn (interval recently saved just before first save) thus at worst losing BOTH saves and tons of grinding!

It would also be nice if someone could make a helper app to change RA’s global settings in case of messing up menu input or something else breaks after tinkering settings then finding that it saved them when using Home to exit RA. This alone could change both global and core specific settings if you can access the downloaded cores to gain access to the lists of settings for each core,or otherwise look at the same cores server to grab all settings for each and every core for Android that you can change for any given core dynamically and edit afterwards. With that,you could change everything,also without having to reflect changed menu inputs in order to navigate and select things in the off chance you delete a vital navigation button during mapping them like the selection button that is the only way to remap stuff that becomes inaccessible and immediately locks you out of using RA,requiring you to edit or delete the configuration in order to restore the input for selecting options to fix it,a helper app could quickly fix it.

Its cumbersome to edit the configuration file on Android via a text editor bc you don’t have a computer’s simplicity of opening something like notepad to immediately edit the custom core config directly from a reserved folder task on a taskbar to tinker with things.

I wish Android had a full computer style option to get the best of it all like a Windows style UI with fully functional keyboard and mouse access. Still can’t so much as touch anything in RA on Shield TV.

1 Like

Hi Ben. Thank you very much for your in-depth thoughts on this topic.

Even if I wanted, I can’t edit these files because my device is not rooted and usually there’s no access to the config files on unrooted devices. But even if I could, I doubt that it would lead anywhere. Apart from the slow performance I noticed other problems like black boxes instead of textures, pixel-garbage, foreground/background confusion and objects on the screen that don’t belong there.

I also just tested Conker, Banjo Kazooie, Banjo Tooie, Kirby 64 and Castlevania and they all have problems of some kind. Mostly performance.

There is for me no use to go deeper into the details. I just wanted to find out if its possible to easily emulate most N64 games on the Fire Stick. And the answer seems to be “No”. The only game that works at first glance is “Super Mario 64”. But I only tested the first star in first three levels. Maybe there are problems later on.

I’m usually more into 2D retro gaming with the 8/16-Bit consoles of the 80s and early 90s as my favourites. And in this respect RetroArch works much better on the Fire Stick than I ever expected. It’s a great piece of software and it has a great forum with very nice and helpful people like you.