Flycast audio reverb missing

So I’m messing around in the Virtua Fighter 3tb sound test and I notice a bgm doesn’t quite sound the way I remember hearing it on the actual hardware. The song Blandish Fist has a long reverb at a certain part of the track that’s completely missing on Flycast. Here’s a recording of how it’s suppose to sound

From 1:04 to 1:07 you can hear the extended part of the track I’m talking about. Now here’s a recording of the song through Flycast on the sound test.

https://streamable.com/fdr3m

At the 25 second mark you can hear the part where the extended reverb should be just fade out. I remember reading that enabling DSP in the options gives the audio more accuracy but even with that enabled the audio still fades on that song and maybe on other songs as well I’ve yet to test. Is there any way to fix this?

2 Likes

The DSP is used for this reverb effect. This is noticeable when you leave the sound test menu while a sound or song is playing.

However it doesn’t sound completely right in this case as I can hear some distortion and low volume sound loops. Probably some bug in the DSP emulation.

2 Likes

@flyinghead i think i saw some updates to dc/naomi/atomiswave sound emulation a few months back in MAME, maybe that would be worth investigating ?

2 Likes