Flycast latest update.....closes when launching a game

hi members and devs , i just updated to 3592cad about an hour ago and simply Retroarch closes after selecting/launching a game. Atomiswave , Dreamcast and NAOMI are affected. Just reporting a small bug and i’m very grateful for the Flycast core.

cheers guys

In case it helps, do you have run-ahead on? It crashes the core for me.

hi c9 , run-ahead is off.

Update…just tried this version on my Vewlix Clone PC and same behavior (launch and closes Retroarch)

Has it ever worked for you? I’m using vulkan video driver, btw. Do you think it’s a setting you may have changed? If so you can try deleting \RetroArch\config\Flycast

yes it has worked fine for me and i’m using Vulkan too. I just tried gl and both Atomiswave and NAOMI worked.

I also deleted the setting in \RetroArch\config\Flycast and Vulkan still has a problem.

@s8n i just reverted the commit that i think might be the culprit if it’s only affecting vulkan, it should be available from the buildbot soon, let me know if it fixes your crash.

Can i have some information on your setup ? I’m mainly interested about OS and gpu.

hi Barb , i just updated to 853adf9 and Vulkan is running sweet with NAOMI and Atomiswave. I will post my setups below

Main PC , Win 10 AMD Radeon RX 570 / Vewlix Clone PC , Win 10 AMD Radeon HD 7850

thank you for looking into the situation

cheers mate

@s8n Do you happen to have a log of lr-flycast (3592cad) when it was crashing?

I am the one that submitted a patch that caused the crash and I am trying to figure out why this issue occurred in Windows but not Linux evidently…

Do you also have up-to-date Radeon drivers and Vulkan SDK? I’m trying to narrow down the basics.

hi blue , i just generated a log from the Viewlix Clone PC which is still running 3592cad i will post it below. I’m not running the latest AMD Drivers on both PC’s. Main PC is 20.9.1 and Vewlix PC is on 20.8.3. Vulkan SDK i’m not sure about that.

@s8n Thanks for the log…It seems that your RetroArch fronted is initializing itself in D3D11. Is that what is set as your video driver? (See lines 24 & 28 of your log)

I don’t believe that lr-flycast supports switching the video driver through the core, but I don’t know for sure. Perhaps @BarbuDreadMon can answer that?

If you set the video driver to Vulkan, (Settings->Video-Vulkan) does it still crash?

Update: I just set my RetroArch to D3D11 as the video driver, and the context selected was Vulkan and it didn’t crash either.

That’s not a core feature, that’s a frontend feature, and it’s enabled by default (and should never be disabled tbh). I don’t think that could be the issue here if updating the core solved the crash.

That’s not a core feature, that’s a frontend feature, and it’s enabled by default (and should never be disabled tbh). I don’t think that could be the issue here if updating the core solved the crash.

Per his log, @s8n is also using a build of RetroArch that is 11 Aug 20. My build of RetroArch in Wind 10 is 27 Nov 20.

Perhaps updating RetroArch to the latest version is in order?

Seems like a good idea, but i still don’t think that could be the issue if reverting that vk context commit fixed it.

@s8n please check if newer build (should be d545abd) still works for you, and please post the logs again (even if it works, i’m having some doubts about amd gpus really being vk 1.1+ compliant so i want to confirm something)

FYI: the option “Allow Cores to Switch the Video Driver” in Settings-Core never worked for me with flycast.
It crashes every time. (Windows - AMD Radeon HD 6800 Series - d3d11 Driver)
I had to create manually a "Flycast.cfg" in Retroarch/config/Flycast with this content:

video_driver = "glcore"

hi Barb , sorry for the late reply (mental health). I just updated to 20caf3f and it runs like a champ with Vulkan. Log posted below with 20caf3f running …

looks good, thanks for the feedback

Hello good Morning. I have a similar problem on Android, after updating to Retroarch Plus from the Play Store the FLycast core no longer works. So much Dreamcast, Atomiswave or Naomi, all the logo of the game appears and when you give it to play retroarch closes.

My device is a Realme X2 Pro, Snapdragon 855 Pro, 12Gb of ram and the latest Android build. Say that with the previous version of Retroarch (before being cut) Flycast worked perfectly without any problem. I have the bios in the system / Dc folder (as before), I have tried with both Vulkan / GL graphics options and also several versions of the core, old and modern …

I hope someone can offer a solution, thank you very much.

Thanks for helping me, you have been very kind …