Flycast - NAOMI: Unable to play games

I’ve setting up RA for the last couple of days. Everything has been going smoothly…until i ran into configuration problems with NAOMI (Flycast). I just can’t figure out what i’m doing wrong. My BIOS location and md5 are correct, but every single game i tried gave me some type of error:

  • Toy fighter (MAME romset): Boot to NAOMI Bios, then stuck into loop. Can’t do anything outside testing

-Toy fighter (.dat file): Same problem

  • Slashout (.chd file): ERROR-01 THIS GAME IS NOT ACCEPTABLE BY MAIN BOARD. I straight up don’t know what’s the problem here. Maybe i’m placing the .zip + CHD in the wrong location?

  • Virtua NBA: Boot to bios, stuck in a loop. Tried to change regions, etc, nothing works

What’s happening here? help! @hunterk

Not sure what’s going on here. These games are supported.

For slashout, put the CHD in a folder with the same name as the zip:


I tried to run Toy fighter again and it still boot into the NAOMI bios:

I tried changing the region and different MAME roms, but with no luck. I’m stuck in the boot - bios - boot loop.

In the case of slashout, after following your advice, i get ERROR 01:

I honestly don’t know what i’m doing wrong

PD: By the way man great work with the Dreamcast core, i’m a big fan of the console and being able to play most of them again it’s like a dream to me! thank you

Error 01 should be because of wrong (or misplaced) romsets, make sure you are using + + gds-004.chd from latest MAME. Assuming your paths are correct (gds-004.chd inside a subfolder slashout in the same folder as, are you loading the romsets from some “weird place”, or from local disk ? I remember fixing a similar issue when loading from a NAS a long time ago.

For Toy Fighter, since it hangs after loading the game, i would suspect a bad eeprom maybe ? Try deleting &, they should be somewhere in your savefiles for this core.

Tried toy fighter from mame 0.209. Still stuck in the system menu options, even after deleting both .nvmem and .eeprom files from the save folder under reicast/flycast. I just won’t load

I understand that Toy Fighter doesn’t use .chd files but the MAME romset instead, so maybe that’s part of the problem?

Slashout it was indeed a misplaced path. It works properly now!

Ok, i just noticed after looking at your screenshot above that you never mentioned something : you are using the 15k dipswitch. 2 things to know about that dipswitch :

  • it has yet to prove its worth, afaik there is only one game (waverunner gp ?) that’s changing based on that setting (switching from 480p to 480i, i don’t understand the point but since it was requested…)
  • in the case of toy fighter, it seems to indeed cause your issue

Basically, disable this core option, and i would recommend to try games at default settings before changing them.

After the feedback in this thread in can confirm that everything it’s now working properly! i even tried some NAOMI GD Roms and they work too

Let this thread be a guide for anyone who needs to troubleshoot with NAOMI on RetroArch!

Thank you guys for you answers