Flycast on MacBook Pro

Hello everyone, it’s my first post here, I hope someone can help me.

I have a problem with Flycast core on my Mid 2014 MacBook Pro, I tried both Metal and Intel version, stable and nightly. When I load the core and try to load a content from my dreamcast directory, I have a black screen and it pops up the message “The Core is not compatible with the current video driver”, then suddenly RA freeze.

This happens with both Retroarch 1.7.8 and 1.7.9

On Windows everything runs fine with no problems.

Thank you in advance to everyone can help me,

The Metal build definitely won’t work. The OpenGL build might, but Apples drivers may not provide a high enough GL level to work.

Thank you for your kind reply. So there’s nothing that I can do to fix this? Maybe updating apple drivers or the new Catalina Os? I’ve tried Redream and works good except fore the WinCE based games that are not supported

Flycast should work fine on OSX with the OpenGL driver.

I’ve upgraded the entire system with the new OSx Catalina. I’m working with the MacIntel version of RA. (1.7.9. v2) Video driver set on GL setting. Core updated to the latest version (0.1 0643e6a) Still don’t work.

Maybe the problem is the intel graphic card? Is it supported?


I have the same problem with a MacBook Pro mid 2017. I also tried with both version and always the same message :sweat:

Hello, for me flycast works very well, just modify the file by removing the last line: 'required_hw_api = “OpenGL Core> = 3.0 | OpenGL ES> = 2.0”


best regards,

Hi! Thanks for the advice!

With this trick I’ve managed to load dreamcast and naomi contents successfully, but only at 20 FPS. Maybe the core is not compatible with my system.