Flycast sprites glitching

After about 10-15 minutes of playing SF 3rd strike, the sprites begin to go haywire and glitch all over the place within the characters rendering area. Ive seen other people post about this a few times but I cant seem to find a straight answer on how to resolve it. Ive updated my core to the latest build and no texture upscaling is enabled. Halp

Here are my core settings: reicast_allow_service_buttons = “disabled” reicast_alpha_sorting = “per-triangle (normal)” reicast_analog_stick_deadzone = “15%” reicast_anisotropic_filtering = “2” reicast_boot_to_bios = “disabled” reicast_broadcast = “Default” reicast_cable_type = “TV (RGB)” reicast_custom_textures = “disabled” reicast_delay_frame_swapping = “disabled” reicast_digital_triggers = “disabled” reicast_div_matching = “auto” reicast_dump_textures = “disabled” reicast_enable_dsp = “enabled” reicast_enable_naomi_15khz_dipswitch = “disabled” reicast_enable_purupuru = “disabled” reicast_enable_rttb = “disabled” reicast_fog = “enabled” reicast_force_wince = “disabled” reicast_frame_skipping = “disabled” reicast_framerate = “fullspeed” reicast_gdrom_fast_loading = “disabled” reicast_hle_bios = “disabled” reicast_internal_resolution = “640x480” reicast_language = “Default” reicast_lightgun1_crosshair = “disabled” reicast_lightgun2_crosshair = “disabled” reicast_lightgun3_crosshair = “disabled” reicast_lightgun4_crosshair = “disabled” reicast_mipmapping = “enabled” reicast_oit_abuffer_size = “512MB” reicast_per_content_vmus = “disabled” reicast_pvr2_filtering = “enabled” reicast_region = “Default” reicast_render_to_texture_upscaling = “1x” reicast_screen_rotation = “horizontal” reicast_show_lightgun_settings = “disabled” reicast_show_vmu_screen_settings = “disabled” reicast_synchronous_rendering = “disabled” reicast_system = “auto” reicast_texupscale = “off” reicast_texupscale_max_filtered_texture_size = “256” reicast_threaded_rendering = “enabled” reicast_trigger_deadzone = “0%” reicast_vmu1_pixel_off_color = “DEFAULT_OFF 01” reicast_vmu1_pixel_on_color = “DEFAULT_ON 00” reicast_vmu1_screen_display = “disabled” reicast_vmu1_screen_opacity = “100%” reicast_vmu1_screen_position = “Upper Left” reicast_vmu1_screen_size_mult = “1x” reicast_vmu2_pixel_off_color = “DEFAULT_OFF 01” reicast_vmu2_pixel_on_color = “DEFAULT_ON 00” reicast_vmu2_screen_display = “disabled” reicast_vmu2_screen_opacity = “100%” reicast_vmu2_screen_position = “Upper Left” reicast_vmu2_screen_size_mult = “1x” reicast_vmu3_pixel_off_color = “DEFAULT_OFF 01” reicast_vmu3_pixel_on_color = “DEFAULT_ON 00” reicast_vmu3_screen_display = “disabled” reicast_vmu3_screen_opacity = “100%” reicast_vmu3_screen_position = “Upper Left” reicast_vmu3_screen_size_mult = “1x” reicast_vmu4_pixel_off_color = “DEFAULT_OFF 01” reicast_vmu4_pixel_on_color = “DEFAULT_ON 00” reicast_vmu4_screen_display = “disabled” reicast_vmu4_screen_opacity = “100%” reicast_vmu4_screen_position = “Upper Left” reicast_vmu4_screen_size_mult = “1x” reicast_volume_modifier_enable = “enabled” reicast_widescreen_cheats = “disabled” reicast_widescreen_hack = “disabled”

AFAIK, the only fix currently for the weird sprite stuff is switching to the vulkan renderer.

As far as I can tell, this only happens in 3rd Strike. No other fighting games with character sprites exhibit anything like this. This is the original thread from this screenshot since i kept forgetting to take a pic of mine and they were having the exact issue, but i’m not sure of what they are saying they did to fix it. If anyone can interpret their solution for me it would be much appreciated. I will try the vulkan renderer to see if i get any different results. From all the other threads ive seen the issue seems to point to a resolution issue but i dont have it upscaled or anything obviously and retroarch window is running 1080p fullscreen so im not sure what the problem could be

The resolution issue had different glitches, before it was fixed (vertical and/or horizontal white lines around characters). This glitch was fixed a few years ago, and seems more like a regresssion of the core for that game. But you say it happends randomly/after a while, so, that’s new…

Switching the renderer to Vulkan definitely seems to stave off the sprites from glitching, although a piece or two of them begin to do it, it doesnt freak out nearly as much as the example in the picture or what it was doing with the GL/GLcore renderers so i may just call that a win haha. Hoping for a more solid fix in the future though but this will suffice

Did you try sorting “per pixel”? (vulkan only)

i didnt try per pixel but i will try that when i get a chance to see if it reacts any differently