fMSX new features: memory configuration, support for .dsk & .cas files


#1

Hello MSX fans!

I’ve just submitted changes to the fMSX core adding support for .dsk (disk) & .cas (cassette) images, as well as allowing memory configuration. Hopefully they will be accepted soon!

DISK SUPPORT

Only .dsk files are supported. There’s still some way to go for perfect disk support, as it’s not currently possible to swap discs. If disk swapping is in another core, let me know, and I will port it over to fMSX.

Aside: you can also use dsk2rom to convert .dsk images to .rom images

CASSETTE TAPE SUPPORT

Only .cas tape files are supported. There is currently no way to rewind or swap cassettes. Help needed testing this support.

MEMORY

Main memory can now be set to Auto|64KB|128KB|256KB|512KB Video memory can now be set to Auto|32KB|64KB|128KB|192KB Auto (default, recommended) also sets both types of memory to the recommended values based on the MSX mode you are using:

MSX1 = RAM 64KB, VRAM 32KB MSX2 = RAM 128KB, VRAM 128KB MSX2+ = RAM 256KB, VRAM 128KB

These changes mean that the default mode of MSX2+ will have more memory available and be able to run more games. This was my goal for these changes.

TO DO/HELP REQUIRED

Touch screen for RetroArch on Nintendo 3DS. If there’s a virtual keboard in another core, let me know, and I will port it over to fMSX.

search for: fmsxcore


#2

great work! glad to see one of the older cores get some love :smile: I know beetle psx has multi disc support, maybe you’ll be able to make fmsx use the similar functionality in retroarch.


#3

Thanks, I’ll take a look.

The FMSX changes are now in the nightlies.

Looking for feedback on the .cas support.


#4

I’m trying to test some msx .cas games from the tosec set and i am having trouble. Maybe im typing the commands wrong, the commands are in the file name but i must be doing something wrong. for instance the: Afteroids (1988)(Zigurat Software)(ES)[RUN’CAS-’].cas and i type this(i have it set to keyboard in controls btw)

Any idea what im doing wrong?


#5

Hi @nonekiller001 — you’re almost there!

Some characters can’t be present in filenames so they have substituted them. It should be:

RUN"CAS:"

KEY ’ means "

  • means :
  • means ENTER/RETURN

You will probably get Device I/O error at that point, which is an issue I am looking into.

As an aside, I had an idea to look for those kind of commands in the filename of what you are loading (mainly cassette but some disks could benefit) and automatically type them into the emulator. This will help usability especially on platforms without a keyboard (I use Nintendo 3DS).

Finally, I have just pushed an update for the fMSX core to bring it from version 3.9 (May 2014) to the most current version 4.9 (March 2017). Should be accepted soon.


#6

Thank you for the great explanation, i get Device I/O error, just as you said. I’m getting excited to test all these games out :smile:


#7

@nonekiller001 most games should also be on disk, which will be an easier way to play.

Also, I find the MSX MANIA disks to be better experiences, they are pretty much guaranteed to work. Let me know if you can’t find them!


#8

Thanks for the advice, also i forgot to comment on you adding reading the filename for loading commands. I think it’s a great idea, maybe make it so you can turn it on and off in core options? So if a user doesn’t want that they can turn it off.


#9

If I can do it, I’ll make it an option.


#10

Just curious why you use fmsx rather than blueMSX?

I’ve got the feeling that last one has better emulation, particularly for the sound. If you try Aleste 2 in fmsx the music is really strange and the digital voice only produces some strange noise.


#11

One simple reason: because I use RetroArch on Nintendo (New) 3DS, which only has fMSX

…beggars can’t be choosers!

would love more cores on the 3DS.


#12

Hi guys,

I have a gigantic doubt to run .dsk games like Aleste 2, which are above 2 files

I tested both emulators fMSX and BlueMSX and had those same results

I tried to run through the file Aleste 2 (Compile, 1989) (Disc 1 of 3) .dsk it requests the second file and this image appears and I can not get out of it nor select the second disk by retroarch,

I created m3u to test with the following lines:

Aleste 2 (Compile, 1989) (Disc 1 of 3) .dsk
Aleste 2 (Compile, 1989) (Disc 2 of 3) .dsk
Aleste 2 (Compile, 1989) (Disc 3 of 3) .dsk

this image appears

without success

I put the 3 files in a .zip file, I presented another screen already of the selection of weapons, however when selecting the weapon appears another screen I believe is requesting another disk.

I tried to use the program dsk2rom, this other screen appears, but upon realizing it seems that the .rom file that was converted seems to be bad dump and does not leave the front and with a very bad sonority in fMSX.

can anybody help me?


#13

No and I think nobody will ever answer this to you. MSX fans are not very fond of sharing their discoveries. I’m trying to do this you want to do for more than a year, with no success. And I’m from Brasil, one of the countries MSX went more well in the world. Nobody helped me and I think nobody will. I even think that this you (and I) want to do is impossible. :frowning:


#14

I’ll try this as soon as I can


#15

Can you provide a save state for this game? @brunobelo @azvarel