Gamecube Controller not an option in Dolphin

I’m trying to play Wii games, using the dolphin core, that are compatible with Gamecube controllers, except “Gamecube Controller” is not showing as an option in Quick Menu>Controls when I have a Wii game loaded.

It shows up for Gamecube titles, and I know for sure that Rampage Total Destruction supports the Gamecube controller. I also tried Resident Evil 4 (Wii ver) to make sure I wasn’t crazy.

For something like Resident Evil, you ‘can’ just switch it to “Wiimote+Classic Controller” but there’s a few games, like Rampage, that support GC pads, but not Classic Controllers.

There’s also layout differences, and on screen prompt differences, etc etc.

Am I doing something wrong? I even tried loading up a Gamecube game, setting the controller type to “Gamecube Controller” and then saving a core remap - but when you go back to the Wii games it just doesn’t respond at all and now it says just “RetroPad”.

Someone has to add Gamecube Controller Compatibility for Wii Mode