GearColeco for Linux-ARM?

Has anyone compiled a version of GearColeco for Linux-ARM? I don’t have an appropriate open system currently to do this with. I’m wanting this because it has support for the purple & blue Super Action Controller buttons. Without those options, the SAC related games can’t really be played.

There was a blueMSX “2.8.3 beta” version that does support the extra SAC buttons, but I’ve only seen that available on Windows, and I don’t believe any of the standard libretro builds actually support core options for those 2 extra buttons (Fire3/Fire4).

Thank you!


On which device are your trying to run it ?

You can try this repository for armv7-hf-neon platform.


Wow, thank you so much! I actually updated the settings on my Windows Retroarch CFG to download the shared object core file, and I copied the file to the gamestation-pro SD card, and was able to launch a file with it! It’s kind of a closed environment where you can’t really use the menu system properly or a keyboard, but I should be able to tweak config file settings to get it to work better! Thanks again!

FYI, FBNeo also supports coleco SAC games with the extra buttons.

Great, thank you, I will check that out! Is that implementation meant for PAL CV only? Turns out unfortunately that the Gearcoleco linx-arm core I was testing with (as previously linked to in this thread) easily gets messed up handling controller functions, at times randomly performing other button actions. Also it seems in general you are not able to define custom assignments for blue, purple, zero, or 9, and I could never got those to work as expected, and they never worked by default either. There was a lot of intermittent funkiness depending on a sequence of buttons you might press.

No, on the contrary i believe only NTSC CV romsets are currently supported.

Make sure you read the documentation i linked in my first post, as you’ll never be able to run any coleco game with FBNeo if you don’t.

Thank you, I see what you mean. I got it to work with the command line, just have to see how well I can tweak the controller mapping. Seems more promising so far than other cores I’ve tried, coolCV, blueMSX and gearcoleco.The Linux environment has a custom Retroarch build that disables kbd and forces the North button (Xbox type Y) to invoke the menu which was customized, so what would normally be assigned to Y has to be mapped to another button action. In testing on Windows, I couldn’t get it to work right through the menu, but also got it working via command line using almost identical syntax except for the library core file, and had to use a newer coleco DAT file for Windows. I’m not sure if it’s using the DAT file or rdb I have there on Linux, but I wonder if I could figure how to make a zip for a rom not listed there such as add Bruce’s controller tester or other to that file, although I used the 1983 SAC tester ROM which is built into the current library list. Thanks again!

So close… :thinking: I can’t get the #1 or #2 keypads mapped, but everything else I can configure. In Windows, remapping values go from 0 to 23, but with Linux it is only recognizing 0 to 21. Values of 10/11 should be #1 and #2, but under linux they are #3 and #4 (this has not been an issue with other cores generally on this system). I can reassign the available values anywhere, but it’s as if there was something missed in this linux build, but I’ll keep checking.

[UPDATE] using a newer build from what was available in the @gouchi post, I think this might resolve the issue, but we’ll see. :grinning:

That’s because you are using latest FBNeo version in windows and an extremely old one in linux. The bug you are mentioning is something i fixed 2 years ago.

1 Like

Thanks, your fix must be in what I downloaded from that other site, since it’s all working now! Good for a retropad type controller anyway. Thanks for fixing that! Next I’d like to see if I can get a true SAC controller working with a USB adapter on linux-arm, but I’m not sure if the mouse/spinner actions will work properly in the subsystem framework. I don’t have the means currently to compile my own standalone emu that might otherwise work like some Windows emus do that support the actual ancient controller hardware.

Does the latest fbneo + coleco for linux support mapping 2 physical controllers to the same controller port (remap files)? For some reason setting p1 and p2 both to “0” in remap files, they still behave like independent devices instead of acting together as the primary controller.

nvm I think there’s another issue I have causing the problem…