Genesis Plus GX slows down on 1 enemy in Thunder Force IV

When the miniboss fires his spread gun the game runs in slow motion until the bullets leave the screen, so far this is the only time I have encountered this in this game. I’d really prefer playing the game at normal speed and the same thing happened in picodrive to a lesser extent, so I’m thinking it’s probably a problem with my settings. I’m using vulkan on a gpd win 3 and made a video showing the slowdown in all it’s bullet time glory. Please tell me there is a switch to activate the blast processing. PS: I’m using the japanese ntsc version of the game.

Is that how it runs on real hardware?

Also, i think there has to be an overclock option somewhere.

That should be how actual hardware works and not a fault of the core. But I don’t have a real Megadrive to test.

Every YT video I checked out that shows this boss fight displays slowdown at that very area. Some even said “actual hardware” in the video title (who knows?). It’s been wayyy too long since I’ve played that on a Genesis/Megadrive to even remember how it actually went.

Given that even Neo Geo slows down on large objects, it’s not surprising it does so on Mega drive.

As a thought, would the “Remove Sprite Limit” option that is in the core options possibly fix this? Not sure what it might do to other sections of the game, but I see it in the Genesis Plus GX core options

I believe that is to remove flicker on sprites that exceed the maximum allowed number. Usually these sprites that slow down are drawn using the CPU. The CPU then can’t keep up and is drown causing the slow down.

1 Like

The cpu overclock option will get rid of that lag, which is happening on real hardware.


Thanks for the input. I’ll give the overclocking a try. I just want to play the game at a regular frame rate, even if it isn’t exactly authentic.