Genesis Plux GX - PAL game that runs too fast [SOLVED]


#1

Hi there, today i tried some gg / sms roms with this core and one in particular happened to run too fast (music especially), The Excellent Dizzy Collection PAL version, looks like it’s being forced to run at 60 hz when, being PAL, should be locked at 50 hz. Is there a solution for this?

Here’s the proof, i recorded it personally: https://www.youtube.com/watch?v=h3mrZQBqUgA

This is the proper speed, as it should be:


#2

Change the region to EUR/PAL in the core options.
Auto-detection isn’t working fine in that emulator.


#3

Thanks, so the “auto” tricked me, i thought it was working properly.


#4

No, auto-detection is working fine. This game is technically not a Master System game but a Game Gear game (running in MS compatibility mode) and all Game Gear are running at 60hz by default, including PAL ones, so 60hz is the correct speed for that game.

https://segaretro.org/The_Excellent_Dizzy_Collection


#5

Yeah sometimes we PAL users remember games the way they were not meant to run. Even as a young boy I noticed Shadow of the Beast was actually much better on a GG with the Master Gear converter than on an actual PAL MSII, but of course I didn’t understand why. It wasn’t until the ps1 that I learnt about the differences between 50 and 60hz. What a turning point that was. Ah, nostalgia…


#6

Every European only Master System game I tried is running at 60fps in RA.
So I’m not sure if that’s a bug or not?


#7

This is not a bug, this is a design choice. Master System games are not region-protected, there is no way to detect NTSC or PAL exclusive games apart using an internal ROM database and most games run better (i.e more enjoyable speed) at 60hz anyway.

So by default (auto), Genesis Plus GX emulates a NTSC console and only emulates PAL console for the few games that require PAL timings to work properly (see database in https://github.com/ekeeke/Genesis-Plus-GX/blob/master/core/cart_hw/sms_cart.c).


#8

Remember for have smooth scroll in PAL games you have to set the video-mode to 50Hz…


#9

ekeeke, the Sega CD Terminator game is not working on genesis plus GX. Lock up after the initial movie. Neither comes the menu. Could you take a look? Thank you!


#10

It works fine, there may be something wrong with your ISO.


#11

Hello. My ISO works fine in Kega Fusion. But I want to play in Retroarch that is way better.

I’m using Win 10 x64, Retroarch v 1.7.5, Genesis plus GX v 1.7.4, Vulkan and shader nnedi3.

If someone can look at it I will be very grateful !


#12

manually set to PAL since unless it still is not working…


#13

good to know!!! are the nes and snes cores handling PAL games the same way like the Genesis Core do with the Master System games?


#14

I just dont know what to do. I tried everything. Cant play Terminator Sega CD PAL or NTSC. But in Fusion runs ok. Giving up…


#15

Just tested the NTSC-U version (ISO+Wav format) and it works fine in Retroarch with any BIOS version.

Make sure you have controller settings set to Joypad (Auto) for both ports as it initially hanged for me after the spinning Virgin logo because I had Teamplayer multitap configured (the game probably hangs when used with incompatible input peripheral)