[Guide] Play Neo Geo CD games using FBNeo

following this guide to the “T” should make the game playable. only reasons that this wouldn’t is that:

1- you are using an older fbalpha core… 2-you are using an older retroarch version for the system you are playing 3-incompatible cd image format, probably something wrong with cue sheet, or paths 4-in some reasons, subsystem just dont work correctly in the platform you are using in on.

no logs and no details of system wont give a faster diagnosis

As i already said, make sure your RA is up-to-date (latest nightly), several gui subsystem issues were solved a weeks ago.

1 Like

You were spot-on, it was the subsystem issue and a new nightly update fixed it. I can’t get it to load through the rgui no matter what I try, but from a command prompt it works just fine.

Ty again.

Ok. Finally got neo geo cd working on Android after days of fiddling. What I did was put neogeo.zip, neocd.zip and neocdz.zip in the system folder. Then I downloaded the mame core (not numbered and fully up to date). Then I made a folder in the system folder called mame, then a folder inside of that called hash, with files neogeo.xml and neocd.xml in it. Then I download my chd file, I made folder called neocdz folder anywhere. Put all 3 bios in that folder also. Then make a folder in neocdz with the proper chd software name. My game is neo driftout so my folder is called neodrift. I put my properly named .chd file in there.

neo driftout (1996)(visco)(jp)[!].chd

Last thing I did was make a empty properly named .zip file called neodrift.zip and put it in my neocdz folder. Launch neodrift.zip with mame core and your good to go. Everything works including music.

1 Like

I did all tutorials’s steps but It does not work. Load the bios screen with neogeo cd logo, show track selection menu but is not launching the game. I have tried cue+iso , cue + bin, cue +img … Any thoughts?

My method above I also tested on windows and it worked perfectly too. You can convert your cue/bin/wavs to chd with chdman.

1 Like

You just switched to using MAME instead of using FBA though, unless I’m misreading your previous post. Had me intrigued for a second there when you were mentioning chd.

Yeah I couldn’t get FBA to work for me, I did try, but I kept getting different errors with FBA over and over. MAME was simply enough and I got it to load everything I’ve thrown at it so far.

good for you, but this is an FBAlpha thread though…

i don’t know hard you tried but i get my neogeocd working so far ( i dont have much, only exclusives, uhm… iron clad…)

Might as well mention it : an issue in fbalpha neocd implementation was fixed today (https://github.com/barry65536/FBAlpha/issues/12), it was preventing some sfx from working.


Might as well warn you : fbalpha ngcd support is undergoing a massive rewrite upstream :

  • cue/iso/wav format will be dropped (maybe it’ll come back later, maybe not)
  • ccd/sub/img (trurip) and cue/bin (redump) will be supported instead.

for verified dumps, i think cue/bin suport is way to go. dont think there are still clonecd images floating around, (imho)

1 Like

Certainly makes things a lot easier to have bin/cue instead of a folder with a bunch of mp3 and etc in it. I take it no word on CHD as of yet though?

1 Like

Neither upstream nor me are interested in this stuff. I would recommend rising a bounty if you want this stuff implemented in fbalpha.

The new code was commited today :

  • TRURIP ccd/sub/img images work
  • Redump bin/cue images don’t work (under investigation)
  • TOSEC bin/cue images i don’t know
  • old cue/iso/wav format doesn’t work anymore
1 Like

great news thank you so much, hope the bin cue format will work somedays . dumb question but is the sound will work on these format? thanks

Yes, and features involving savestates (rewind, read ahead, netplay, …) should now work too. bin/cue seems to work as long as data and audio are in the same bin file.

1 Like

cool thanks again for these features

Another side effect of those changes : samurai showdown rpg now works.

Support for cue with multiple bin files (ex. redump) won’t be added. I recommend using CUETools CDmage to convert whatever format you have to “single file cue/bin” (be sure to set data track to MODE1/2352 when asked). CDmage is way easier than CUETools, and it’s even working on linux through wine, apparently the homepage is down so i won’t give you a link, but you’ll find it easily on any search engine.