[Guide] Play Non-Arcade systems with MAME or MESS

I recommend using the method in the first post - there’s an example for NeoCD to follow. Or use FBNeo for NeoCD

1 Like

I really appreciate your reply, @zachmorris. The link (dummies files) is down. Pls, could you re-upload the file?

Thank you ever so much!

I uploaded quick a gist here with the zip files, and a way to create all the dummy files for any software list.



I’m having some trouble with Philips CD-i. Hotel Mario and Zeldas Adventure run fine but when I try to play the (cdi-ready) games like The Apprentice, I get stuck on a blue screen. I’m on Android and my directory looks like this

Philips CD-i/cdibios/apprentc/the apprentice (cdi-ready).chd apprentc.zip

When I load it, it goes to a blue screen, then the cdi player, then when I press play, it gets stuck on a blue screen. I’ve been searching for answers for hours but I can’t find anything.

This isn’t the main question I have but when I load Link - The Faces of Evil or Zelda - The Wand of Gamelon, it lags like crazy and then freezes.

I think you’re likely seeing an issue with MAME that hasn’t been fixed yet. The apprentice game is listed as a bad dump, and in my experience those games don’t really work.

The same with Wand of Gamelon, it just doesn’t work well / it’s a known bug.

1 Like

Oh ok. That’s too bad. Thanks for the info. I hope it gets fixed eventually.

Hey Zach would u happen to know the trick for atari xegs?..I try with atari800 core but it goes into the self test…then I have to manually select a xegs .rom file and then it loads…also with mame it loads using the softlist but when I try with cmd line it fails…

I tried it with a random game called Commando and it works in MAME using the instructions in the first post:

  1. Create a hash folder and put the hash file xegs.xml into it:
  1. Setup your game directory and put the game files and bios file in the folder:
...path_to_my_game_system_files/xegs (folder)
      commando.zip (game file)
      xegs.zip (bios file)
  1. Load commando.zip from Retroarch or the command line, the game should launch just fine

I didn’t mess much with the controls, but they didn’t seem to work right out of the box, so you’d probably have to update the controls in Retroarch to make them work.

If u have a chance , can u try using command line to launch? …I use it for android but this one is kicking my azz. .lol…I wonder if I’m missing a parameter somewhere …for android I do it like this. .xegs -cart “/games location/xegs/example.rom” …when I launch it, it crashes…but if I place the game in the correct folders it loads…with command line launching, I can have the games anywhere I want

No, I couldn’t get that to work either. It’s complaining about not being able to find a bios file if I try with a cmd file (seems like MAME or Retroarch is looking in the wrong spot for the bios file, and I can’t figure out how to tell it to look in the right spot)

But, why would you do it that way? Thats adding an extra file/step thats not needed. If you set it up in the folder structure described, it’ll work without a cmd file, just point to the game. I tried about 5 other games, and they all worked like a charm using the method I posted.

Edit: I figured it out. XEGS / Atari 810 has some weird command line options. I’m not really sure what they all do (my guess is there just different disk drive types you can plug into the XEGS) but here’s what they are:

---------------- ---------------- ---------------- ----------------------------
xegs             sio              a1050            Atari 1050 Dual Density Disk Drive
                                  a810             Atari 810 Disk Drive
                                  cassette         Atari 8 bit cassette

All of the options seem to boot the game.

Command file would contain the following:

xegs -sio a810 commando -rp ".../path_to_games/my_game_folder/"


xegs -sio cassette commando -rp ".../path_to_games/my_game_folder/"


xegs -sio a1050 commando -rp ".../path_to_games/my_game_folder/"

Game folder structure would be:

...path_to_games/my_game_folder (folder)
      commando.zip (game file)
      xegs.zip (bios file)
      atari810.zip (bios file)
      atari1050.zip (bios file)

The cmd file could then be anywhere. You can launch the cmd file directly in RA or from the command line.

Interesting…I will test 2morrow after work…yea the reason I only use command line is because I use android and I try not to store anything on the nvidia shield itself

If I may…

Whether you are using the standalone MAME or the RA core, specifying the system and/or interface from the command line, (i.e. xegs -cart.) bypasses the hash xml. While this is normally OK and allows you to load ROMs that may not be in the XML or have different names, it can cause problems, (e.g. FM-Towns games that require a boot disk.) and almost always lowers compatibility. (Only 85% of the listed “working” V.Smile carts load from the command line.)

The hash XML will take care of any command line options for you, if you have softlist and softlists_auto_media enabled in the core options.

Some of the core changes in post 0.222 MAME cores have made optional things mandatory. (i.e. CD images MUST be in a folder matching the hash XML ROM name (CD-i, FM-Towns ) and some systems require ROMs to be zipped. (PDP-1, Apple II))

Just the results of my recent R&D. :innocent:

BTW. Here is a shot of the PDP-1 Spacewar! running on the Mega Bezel, using the newly implemented PDP1 hash XML.


Hello !

I am very interested in the DPD-1 how did you get it to work ? & where did you find the wonderful bezel ?

Thanks best regards !

1 Like

It works using the standard method in MAME, put the zipped ROMs in a “pdp1” folder. (ROMs need to be from the MAME SL. It needs no bios. )

Load the ROM as content with MAME (Current). Make sure you have

mame_softlists_auto_media = "enabled"
mame_softlists_enable = "enabled"

in the core options. (config/MAME/MAME.opt or pdp1.opt file.)

The MAME docs list both Spacewar! and Munching Squares to be working but I haven’t had any luck with Munching Squares.

The bezel is actually based on my PDP-1 raster art that is part of the standard MAME xtras and can be found in the usual places like Mr. Do’s arcade or Progetto Snaps…

I have a particular passion for the PDP-1 and Spacewar!. The raster bezel is part of a series I did for MAME and Rocketlauncher a few years back. The rest of the 1080 graphics in that collection can be found in one of my repos.

This version is 99% vector art and 4K. (The room in the background is raster.)

It is one of a collection of graphics I am doing for the Mega Bezel shader.

Information on the Mega Bezel can be found in this thread.

Information on my graphics can be found here.

In addition to the PDP-1 I have also done the V.Smile, FM-Towns, Philips CD-i, and TI-99/4A. (For the MAME core)

I have plans to do a few more MAME SL machine graphics to fill in the gaps in RA cores.

1 Like

@Duimon thank you very much for the bezels it’s really a great job !

  1. On the other hand, I don’t know where to find the roms of the games for the DPD-1 ?!

2 … How to install the bezels in MAME or RetroArch ?

Greetings !

1 Like

Doesn’t look as great as yours woth the blue but I only loaded it to test on Android (nvidia shield)…also tried the other game but not sure what needs to be done to work beside all these crazy designs on screen

1 Like


Looks like you found my original Raster MAME layout. FYI, it needs BGFX enabled for the lamps to line up just right. You can tweak the layout coordinates if you aren’t using BGFX, it just needs a pixel or so.

The other one is just crazy designs on the screen. It’s a visual tech demo. Hmm looks like I need to try harder to get munching squares to work. Did you have to do anything other than start the tape?

Yes … load via cmd …if I load the zip straight up nothing actually loads where its supposed to load (ptp1) i think…most of my softlist stuff i have unzipped due to naming issues and arcade bezels showing up (example is maybe pacman…that name is shared by the arcade rom plus many other mess systems so the wrong bezel always shows up)…I will take a screen shot of how I write the cmd fir android…obviously your on the pc so it will look different but I learned via mame documentation on command line launching…for spacewar i just had to change the name of the rom because an arcade game also shares the same name …I also load chds the same way…no zips just chds…everything except xegs loads woth no issues and no hash file and any name I give it…lately I just keep them zipped and bulk rename everything in seconds and as well as any artwork and preview videos for my android frontend…originally I commented on here because xegs was the only system out of many where this rule doesn’t apply…xegs for some weird reason demands the hash name…

1 Like

Yeah I am familiar with the command line methods and how to develop them. As I said earlier, it works but there are many cases where compatibility is less.

I get nothing but a white dot in the center of the screen with munching squares via both stand-alone MAME and RA core. :frowning_face: