Help managing overlays

retroarch

#1

Hi,

I use Retroarch on a Raspberry Pi. I used a TV overlay with shaders for scanlines but they imply to much input lag. So I tried the effect overlay : mame-cool-4x and it perfect fit PCEngine resolution but not SNES. I wanted to use with the TV overlay I have with the effect overlay mame-cool-4x but only one (the first (0)) is displayed, this is the config i tried for tv-pce.cfg:

overlays = 2
overlay0_overlay = ../effects/scanlines/mame-cools-4x.png
overlay1_overlay = tv.png
overlay0_full_screen = false
overlay1_full_screen = true
overlay0_descs = 0
overlay1_descs = 0

Then I tried to merge the 2 overlays with gimp and then use it but I don’t know why, but the overlay I created perfectly fit the SNES resolution but not the PCEngine anymore.

This is the config I have in retroarch for the overlay application :

video_fullscreen_x = 1920
video_fullscreen_y = 1080
custom_viewport_width = 1361
custom_viewport_height = 1009
custom_viewport_x = 282
custom_viewport_y = 39
aspect_ratio_index = 22
input_overlay = "/opt/retropie/configs/all/retroarch/overlay/borders/tv-pce.cfg"
input_overlay_enable = true
input_overlay_opacity = 0.900000
input_overlay_scale = 1.000000
video_smooth = "false"

I tried to tweak “custom_viewport_height” and “custom_viewport_y = 39” But I did not found a setting that perfectly fit the scanlines.

Any help would be very appreciated,

Thanks by advance.


#2

So I made it.

Good scanlines for PCE Engine and for SNES. These are my settings pce :

retroarch.cfg

input_remapping_directory = "/opt/retropie/configs/pcengine/"
video_fullscreen_x = 1920
video_fullscreen_y = 1080
custom_viewport_width = 1361
custom_viewport_height = 960
custom_viewport_x = 282
custom_viewport_y = 64
aspect_ratio_index = 22
input_overlay = "/opt/retropie/configs/all/retroarch/overlay/borders/tv-pce.cfg"
input_overlay_enable = true
input_overlay_opacity = 0.900000
input_overlay_scale = 1.000000
video_smooth = "true"
#include "/opt/retropie/configs/all/retroarch.cfg"

tv-pce.cfg:

overlays = 1
overlay0_overlay = tv-pce.png
overlay0_full_screen = true
overlay0_descs = 0

SNES:

retroarch.cfg

input_remapping_directory = "/opt/retropie/configs/snes/"
video_fullscreen_x = 1920
video_fullscreen_y = 1080
custom_viewport_width = 1361
custom_viewport_height = 1009
custom_viewport_x = 278
custom_viewport_y = 39
aspect_ratio_index = 22
input_overlay = "/opt/retropie/configs/all/retroarch/overlay/borders/tv-snes.cfg"
input_overlay_enable = true
input_overlay_opacity = 0.900000
input_overlay_scale = 1.000000
video_smooth = "true"
#include "/opt/retropie/configs/all/retroarch.cfg"

tv-snes.cfg

overlays = 1
overlay0_overlay = tv-snes.png
overlay0_full_screen = true
overlay0_descs = 0

The TV design is not mine but the combination with the scanlines yes. There is a little black border on top and bottom of PCE emu but it’s OK.

Here are some shots of the result wich is better in real life :

https://drive.google.com/open?id=1P8MWVNABrXqRZu64ksVyNeTSy871smHN

https://drive.google.com/open?id=1_IBXZGLF8p9X8e43PziMMscK9v8L6ROg

https://drive.google.com/open?id=1YYcXrTiDzlazWEsUWeExXH7dq488iwP7

https://drive.google.com/open?id=1eLFSILmxO-TBReHGpyblGozdY7EE6g38

Config files and overlays here :

https://drive.google.com/drive/folders/1vlKqSzkokr3BU6txeb9XZHLpcZfWYEzv?usp=sharing


#3

Much better removing setting smooth to false.