How do I get NeoGeo CD working in Retroarch

Hey guys,

Am I the only one who’s loosing the NeoCD with Retroarch 1.9.1 ? The core neocd does not work after the update. Have to reinstall the 1.9.0 to play Neocd :frowning: Under 1.9.1, just after launching a game, immediatly back to windows.


@Leatherface Try less demanding shader presets than what you currently use and see if it loads without ctd. Same happens with me with demanding shaders :upside_down_face:

1 Like

I have never been able to get it to work, even without a shader, 1.9.0 or otherwise. :frowning_face:

I can’t get FB-Neo to play them either.

1 Like

Delete config folder, but still the same, back to windows immediatly after launching a game. I’ve reinstalled 1.9.0 and no problem, can play with old shader. Will keep a 1.9.0 on my HD for NeoCD games and waiting a future update on the 1.9.1

Maybe it’s the core updated recently while you have an older core build on your 1.9.0 version of RetroArch that is still works. Could you try copying your NeoCD system core and its config files from 1.9.0 and place it to the RetroArch 1.9.1 and try again and see if it’s work.

1 Like

Well… done this but still the same. When i select Run to launch a game it’s like i’m choosing quit Retroarch, back to windows :frowning:

1 Like

What log file say about that. Did you also enable logging option and see what’s the latest error or warning when you run any content? If not maybe give it a try and don’t forget to enable Log to File option. So when ctd occurs you can check the log in /RetroArch/logs.

First time i’m using logs. Hope that you want. And… see nothing…

And… was lucky to have something because every time the log console stay black :frowning:

[INFO] [CONTENT LOAD]: Updating firmware status for: F:\Emulation\Retroarch\cores\neocd_libretro.dll on F:\Emulation\Retroarch\system
[INFO] [CORE]: Using content: F:\Emulation\Retroarch\roms\SNK - Neo Geo CD\2020bb\2020 super baseball (1995)(snk)(jp-us)[!].chd.
[INFO] [Core]: Content ran for a total of: 00 hours, 00 minutes, 00 seconds.
[INFO] [Core]: Unloading core..
[INFO] [Core]: Unloading core symbols..
[INFO] [Video]: Does not have enough samples for monitor refresh rate estimation. Requires to run for at least 4096 frames.
[INFO] RetroArch 1.9.1 (Git cf6ca2a)
[INFO] === Build =======================================
[INFO] CPU Model Name: Intel(R) Core(TM) i5-4460  CPU @ 3.20GHz
[INFO] Built: Mar 28 2021
[INFO] Version: 1.9.1
[INFO] Git: cf6ca2a
[INFO] =================================================
[INFO] [Input]: Found input driver: "dinput".
[INFO] [Core]: Loading dynamic libretro core from: "F:\Emulation\Retroarch\cores\neocd_libretro.dll"
[INFO] [Overrides]: Core-specific overrides found at "F:\Emulation\Retroarch\config\NeoCD\NeoCD.cfg".
[INFO] [Overrides]: No content-dir-specific overrides found at "F:\Emulation\Retroarch\config\NeoCD\2020bb.cfg".
[INFO] [Overrides]: No game-specific overrides found at "F:\Emulation\Retroarch\config\NeoCD\2020 super baseball (1995)(snk)(jp-us)[!].cfg".
[INFO] [Config]: Appending config "F:\Emulation\Retroarch\config\NeoCD\NeoCD.cfg".

I’m not any good reading log files for sure but it is at least best way to pinpoint the issue and get a soultion for it asking around or searching online.

At first glance it seems like you have a core specific override,

  • Backup your whole core config folder from RA 1.9.1 \RetroArch\config\NeoCD and delete anything from inside of original core config folder,

  • Copy everything from RA 1.9.0 core config folder /RetroArch/config/NeoCD to the RA 1.9.1 \RetroArch\config\NeoCD folder,

  • Delete neocd_libretro.dll from RA 1.9.1 /RetroArch/cores and get the core from RA 1.9.0 /RetroArch/cores instead.

Hope it hepls.

Btw, I’ve tested NeoGeo CD which I haven’t played before and I’m successfuly loaded up a NeoGeo CD game without any crash on RA 1.9.1. So I’ll share what my NeoCD.opt file contains and try that if above solution won’t work. Note that I don’t have any shader setup for NeoGeo CD.

neocd_bios = "front-sp1.bin (Front Loader)"
neocd_cdspeedhack = "On"
neocd_loadskip = "On"
neocd_per_content_saves = "Off"
neocd_region = "Japan"

Here you can see I’m even able to load and play game without issue;

And this is from the menu and using latest Duimon’s Standard preset;

Ps: Since it seems like your issue isn’t related with HSM Shaders in general then I don’t think this is the proper place to discuss this issue here. You can DM me if you would like and I’ll try help you as much my knowledge could possibly offer :upside_down_face:

Ps.02: Also make sure you have NeoGeo CD bios file inside of RA 1.9.1 system folder.


I split the thread so you can feel free to continue the discussion here :slight_smile:


Thank you but after trying everything (Unparallell posts), delete cfg files and others things, NeoCD still crash. Then, i’ve made a clean install, put the NEW shaders and… it works now ! Since years i’ve installed new Retroarch versions on my old one. Think it was time to clean up :wink:


I also got it to work. :grin: Turns out the problem was having both the zipped bios files (That MAME and other cores use.) and the unpacked, (That NeoCD uses.) in the same folder.


Sometimes something Happens on your Computer that no one can Replicate.

At Moment I have simmlar to with Dosbox Pure where I can’t use Save States but no one else seems to have same Problem


Neo Geo CD setup video tutorial