How i can change the resolution in mame-libretro for a Game?

Hallo Friends, my Name is Michael and i live in Germany.

i’m using a retropie image (pikiller) where I just can’t change the resolution in mame-libretro. I’ve tried different options. I’ve tried different options.

Unfortunately, I didn’t find anything in Attract mode either.

can someone please give me tips? i use a Bartop with raspi p3 b

pic01 the pages are not visible.narrow picture (i want full screen, not only in the middle) pic01

pic02 in the menu no option for display resolution pic02


I’m not sure I understood your problem (I have no single-board computer and I don’t use retropie) but most arcade games are meant to be played on a 4/3 display, some of them were using a 4/3 display but rotated so the image that you see is the correct “original” aspect ratio -> 3/4.

In retroarch there are options in

Settings -> Video -> Scaling -> Aspect ratio

In there you can set it to Full, so your entire screen will be used, this can be done in Retroarch, but I don’t know how to get to this options on your operating system. Hopefully someone else can help.

Be aware that to play a 3/4 game fully stretched on a 16/9 display is going to be…ehm…very weird to say the least.

Hello Hari-82, hanks for your answer.

I think I have a 4/3 monitor (look Pic 04) that’s a different image (advmame). the format is great here, a little bit of space on the sides.

no information seems to be stored in retroarch?! that’s funny (look pic 03)

I have to try to find a config via ftp where I can change it manually :pleading_face:

oh if it is a 4/3 panel then I’m not sure of what is going on.

looking at the first image the spacing on the side on centipede looked like a 16/9 panel

this is how it look on my 16/9 screen:

Other than that I’m not sure how to help you on your retroarch install. If it can be useful on windows you can find Retroarch.cfg in the main folder and if a core as it’s own overide you can find the core’s cfg file in main_folder/config/core_name/core_name.cfg

in those config you can look for aspect_ratio_index and maybe set its value to 20, 21 or 22 one of those is the core provided aspect ratio but I don’t remember witch.

Hey Hari-82, thanks for the information. I’ll test it one day and let you know.

1 Like

Many arcade games were made for portrait mode. That is, with the arcade monitor rotated 90 degrees. So instead by 4:3, they were 3:4. Or instead of 16:9 or 16:10, they were 9:16/10:16.

Don’t rotate your CRT monitor though. If it’s not made for this, you could damage it.

Note that if you stretch the game to fill the whole screen, then it’s going to look distorted (wider than it was intended to be.)


Hello Friends, finally had time and was able to continue testing. I was able to fix the problem with the size. fault was one “overlay”. the setting in a config file squeezed my gaming image. i set the value to —input_overlay_enable = “false”—

ok, now my picture is ok.

but i can’t configure my 11 buttons on the bartop. as soon as I start a game and open the input config (Pic02), they are simply not recognized. do I have to activate the keys somewhere beforehand?

If you use the MAME RetroArch core, you have to configure with the RetroArch menu, MAME’s own menu does not work.

FWIW, this one is using a 1:1 ratio and it’s a ratio available in RetroArch. It’s distorted if you compare it to the real cabinet but some people like it that way.