How to load R-Type (Arcade)?


#1

Hello everyone.

I want to play the Arcade version of R-Type. My version of R-Type, that I have downloaded from somewhere, consists of twenty files (I have put the filenames at the end of this post). I have copied all these files in a folder called “R-Type”. Then I downloaded the Mame-Core and the Mame2003-Core in Retroarch. When I go to “Load Content…” the only entry that is listed for this folder is “No items”. Apparently Retoarch can not do anything with these files.

I have never played an arcade game in an emulator before. What am I doing wrong here? Can somebody give me some help, please? I am using a Fire TV stick if this matters.

Greetings, Christian.

rt_b-a0.3c
rt_b-a1.3d
rt_b-a2.3a
rt_b-a3.3e
rt_b-b0.3j
rt_b-b1.3k
rt_b-b2.3h
rt_b-b3.3f
rt_r-00.1h
rt_r-01.1j
rt_r-10.1k
rt_r-11.1l
rt_r-20.3h
rt_r-21.3j
rt_r-30.3k
rt_r-31.3l
rt_r-h0-b.1b
rt_r-h1-b.1c
rt_r-l0-b.3b
rt_r-l1-b.3c

#2

The arcade cores require games to come from sets that are specific to that version of the emulator. So, you can’t just get any ol’ rtype.zip and expect it to work with any ol’ arcade emulator.

If you downloaded mame2003–which is based on mame v0.078–you need ROMs from the 2003/v0.078 set.

Also, you need to keep them in the zip archive and ‘load archive’ (i.e., rather than ‘browse archive’) in RetroArch.


#3

If you google it, you’ll see there are hundreds (probably thousands actually) of topics explaining how arcade emulators work.


#4

So each game has ROMs for every single emulator?

From the site where I usually download ROMs I have chosen “MAME => R ==> R-Type (World)”. There are no specific version numbers given. I assume that “World” is a ROM that can be used worldwide. Like Mega Drive games that are often for all regions.

But I unpacked the files. Maybe it works when I leave them i the ZIP-archive. I try that…


#5

If there’s no number given, you can usually assume it’s for latest (or very recent) MAME, which usually matches our mame core without any year attached to it.


#6

Keep the files zipped. Do not create folders.


#7

The mistake that I’ve made was that I unzipped the files. When keeping them in ZIP archive form, it works. Thanks for your help.

BTW: The performance on a Fire TV stick is really bad. The sound stutters and the scrolling is not smooth. I don’t think I will play it this way. Maybe I opt for the PC-Engine version.


#8

I don’t think that’s normal, at the very least i’m pretty sure rtype will work smoothly on fbalpha with those device specs.


#9

Yeah, latest MAME is very slow on low-power/embedded devices. As BarbuDreadMon mentioned, you’ll probably have better luck with FBA. If that is too slow, as well, you can find an older version for use with mame2003.


#10

I now have tried R-Type with FBAlpha and FBAlpha 2012. It’s better than with the latest MAME. But still not optimal. Sound seems okay. But the scrolling is not perfectly fluid if you look closely. - Nevertheless many thanks.


#11

I have downloaded a version of R-Type for MAME2003/v0.78. Loaded it with the MAME2003 core but it’s not better than the “normal” ROM with the FBAlpha oder FBAlpha 2012 core. It’s playable but the scrolling and sprite movement is a bit fidgety. - Well, I guess that’s the best I can get with my Fire TV stick. Thanks.


#12

That’s still weird, those games run normally on a raspberry, which is less powerful than your Fire TV stick afaik (as long as no arm dynarec is involved). Also, if it was related to cpu usage, you would see differences between fbalpha and mame2003 (fbalpha is more accurate, so it is less cpu friendly than mame2003)


#14

I’m no expert. I have heard the Raspberry Pi is more powerful than the Fire TV stick. Supposedly, the raspberry can even emulate N64 games which is nearly impossible on the Fire TV stick. But I’m still very happy with it. The Fire stick with RetroArch can emulate all the home consoles that I value. The NES, Sega Master System, SNES, Mega Drive and the PC-Engine. Mind you, with a perfect frame rate.


#15

I have a couple of firesticks and would like to try RA in there. Question is what are you using as a gamepad? How did you paired it?


#16

I’m using the 8BitDo SN30 Pro. You can pair it with the normal settings in the Fire TV stick menu. This is very easy and no additional software is required.

The gamepad supports different systems like Switch, Windows, Android, macOS und Steam. If it doesn’t pair correctly or behaves weird or delayed, you must disconnect/unpair it and set it to Android mode first.

This is done in the following way: On the controller you press the B button while turning it on. The first of four LEDs is then blinking. After that you press and hold the pair button on the backside of the controller with a toothpick. The four LEDs then begin to blink like the pulsating red lights on the front end of K.I.T.T. (from Knight Rider).

In this state you can pair it again and it should work.

I have also tested the 8BitDo N30, 8BitDo Zero, 8BitDo SFC30 and the 8BitDo SFC30 Pro. They all work with the Fire TV stick. And no, I’m not working for 8BitDo.


#17

Cheers.

I have xbox controllers; will dig around a little bit, see if I can make them work.


#18

That’s why i said “as long as no arm dynarec is involved”, raspberry is not more powerful, it’s just that the emulator you mention has an arm dynarec, which improves speed a lot on arm devices, and honestly saying the raspberry is able to emulate n64 is an overstatement imho.

There are no such arm optimizations in fbalpha or mame, so there is no reason for those emulators to run better on arm-based devices like the raspberry.


#19

Well, maybe someday there will be a FBAlpha or MAME port with ARM optimization. I look forward to it.


#20

Oh, actually i didn’t think this Fire TV stick device was an arm one. No idea why it’s performing worse than a raspberry then, same arch + higher cpu frequency should actually make it faster.


#21

The Fire TV stick that I own (2nd generation) has a MediaTek MT8127D Quad-core ARM 1.3 GHz processor with a Mali-450 MP4 GPU. It has 1GB of RAM and 8GB of flash storage.

Maybe the Raspberry has a different GPU, faster bus system or whatever. This might be the reason why Arcade games run better on the Raspberry. I don’t know.