How to set up px68k core quick guide? (where to put bios)


#1

Is there a guide for the core? Can’t wait to try some Cho Ren Sha :slight_smile:

Thank you !


#2

BIOS files go into system/keropi


#3

If you follow the last part of this article you should be fine.


#4

how do you get multi disk games to work?, trying Final fight but when i load the first disk it comes up with a message box with Japanese text and options to press either ‘A’, ‘R’ or ‘I’


#5

Thank you guys, i will do as instructed!


#6

some disks requires that you insert disk1 and disk2 together. Final Fight for one.

some disks (at least for D88 fdd’s) requires to set only the disk labeled “system” and when the prompt appears(use mobile google translate :D) remove the system disk and insert “program” on fdd0, “player” or “game” disk on fdd1.


#7

Oh, not very straight forward then, i wont be able to use this core then as im using just a pad for my setup. Hopefully they can work out an automatic system in the future.

So how would i get Final Fight to work then, as i Press L2 on my pad and select disk 2 for FDD1 but im still getting that message box appear


#8

You can use the reset option above when both disks are in fdd0 and fdd1. But, yeah, sometimes when you’re asked for a key press it’s problematic to not have a virtual keyboard. Hope this will be fixed soon.


#9

Yeah i tried that (so FF disk 1 is in FDD0 and FF Disk 2 is in FDD2) but i still get the text box pop up, any ideas?


#10

Then hit “SYSTEM” and “RESET” in that F12 menu, this will launch then, I just did it.


#11

Hmmm, yeah doesnt appear to work for me, i still get the text both pop up!..


#12

looks like corrupted disks, if not, check your bios folder iplrom.dat and cgrom.dat should only be the bios there, remove other iplrom* there.


#13

Hmm just tried another disk image and getting the same issue.

In System/keropi/ i have iplrom.dat, cgrom.dat & Config only

EDIT: i deleted the config file and seem to be working now


#14

Happy as hell this core is finally on the Arch. I had downloaded the stand alone emulator a while back and just took the config from there and copied it to the keropi folder along with the 3 roms and then defined the rom directory within the config and it’s been smooth sailing from there :sunglasses: So far it seems the best way to load 2 disk games is using the cmd method described in this thread for both disks to start automatically, I think it’s a good solution to those who use front ends like Hyperspin. Also for those that don’t know the PC-98 (NEC Neko Project II) core is also up, although it stopped working after I updated it last night.


#15

I’m following the steps but seems like the core is not accepting any input after loading the game. The control that works is L2 to toggle the core menu. What are the correct settings for input devices?

Also, how do you load a game that spans more than 2 disks since there is only FDD0 and FDD1?


#16

it will ask you to insert disks when it needs them. like Amiga/Atari ST/PC with floppy drive etc.


#17

I figured out part of the issue is that some games need DISK1 in FDD0 and DISK3 in FDD1. I also tested a version of Gradius that boots to a GUI OS? but there is no way to move the mouse. I think this is either a bug in the emulator or the libretro port.


#18

In the F12/L2 Menu, keep “Joy/Mouse” on Mouse.


#19

Finally got to try Cho Ren Sha. It works, BUT, the controls only work if i choosing “Superscope” input option. Am i doing it right? It is the way it’s supposed to work? (also compared to other shooters, i feel a little more lag than usual…maybe it was by design).

edit: after further testing and playing, the strange issue with touch controls is that in order for them to work, i have to disable analog option in the core menu (after loading the rom) then enable it again, and then change the input option to any setting (Joystick, /w analog, superscope), i mean, just simply change it. Very strange.


#20

im sorry but ive been trying on Nvidia Shield to set it up. it wont work at all. the core info says my bios isnt in the keropi folder. here’s my questioin:

what?/system/keropi ? is it root/ ? retroarch/system? pk68x/system ??? what about that config fil required?

Thanks guys!