Px68k-libretro


#126

Insert disk2 in the F12 menu (FDD1).


#127

or create a text file with extension .cmd like akumajou.cmd containing something like

px68k "/somewhere/akumajou dracula (1993)(konami)(disk 1 of 2).dim"  "/somewhere/akumajou dracula (1993)(konami)(disk 2 of 2).dim" 

#128

Loading disc 2 in fdd1 worked, thank you. I was expecting it to ask for disc 2 if it needed it, but i guess they’re both needed at start. Another note, after selecting the audio type(option1), it plays the music for a min or two on a black screen before loading the konami logo. just a heads up to people who are trying it as well. give it a min for it to load.


#129

@r-type not sure, it would be better if it worked with the new frontend based osk than the touch overlay, that way it would work with touch, mouse and gamepad.

any plans to implement the disk interface so you can add subsecuent disks via the retroarch menu?


#130

Does the disk interface handle multiple fdd? As explain above for many games you have to load in fdd0 diskb and ffd1 diskb.


#131

what you do with the data internally is up to you, it will just give you the list of media for you to handle in any way you like


How to set up px68k core quick guide? (where to put bios)
#132

interesting ,I never notice it , I will look at

RETRO_ENVIRONMENT_SET_DISK_CONTROL_INTERFACE 13


#133

Not sure how to compile this. I have been in the F12 menu and I just don’t understand what to do. I can make this another thread since it seems Mac specific and most of the talk here is about the overlay.


#134
from r-type doc from github

px68k-libretro

forked from https://github.com/hissorii/px68k backported c68k core from https://github.com/kenyahiro/px68k/ (fork of https://github.com/hissorii/px68k using recent c68k yabause core to support X64 build)

All credit goes to hissorii ( and kenyahiro for updating c68k core) .

How to use :

First create a 'keropi' folder in retroarch system directory. put the x68000 bios files in.

Then launch emulator with some content (dim|zip|img|d88|88d|hdm|dup|2hd|xdf|hdf) F12 to enter menu.

You can launch content with:

    retroarch -L px68k_libretro.so ./content.hdf

    retroarch -L px68k_libretro.so ./content.xdf

    retroarch -L px68k_libretro.so ./content.cmd (cmdfile is a text file contening cmd like "px68k /somewhere/software/x68000/content1.dim /somewhere/software/x68000/content2.dim")

    retroarch -L sdlpx68k_libretro.so "px68k /somewhere/software/x68000/content1.dim /somewhere/software/x68000/content2.dim"

    load retroarch , then load core and content from RA menu.

Bios files needed are “iplrom.dat” and “cgrom.dat”. goto your retroarch-system directory (whatever you assigned this to), make a folder named “keropi” and place these 2 bios files there, then follow guide above to launch games.

also, unzip your romsets since autoloading will not work with multiple fdd type games— single-floppy games (like twinbee, chorensha) can be left zipped if you want and load using retorarch Load Content way.


#135

Sol Feace dont work anymore for me, It was fine before Is it running OK for you ?

Thanks


#136

works fine here. i dont understand japanese so not sure if this is the correct way to play the game but here is how im making it work(assusimg 3-disk version .DIM format)

-insert disk1 to fdd0 ONLY (do not insert disk2-leave fdd1 empty)

-wait for the demo to finish(intro-not sure if this is normally should be)

-when the demo finishes and "blue" window appears(this is asking for the disks to be inserted), insert disk3 to FDD0 and disk2 to FDD1, then go back to game (F12 or L2-DO NOT RESET)


#137

Thanks for your reply and your help Its not working. I have a black screen after I change the disks What is strange is the game was working perfectly before I did nothing except update the core


#138

Aquales also is not working anymore for me


#139

wrong sequence of disks inserted or with a disk in fdd1 which is suppose to be empty will render just black screen. check the steps again. else, restore your disks from backup as they may have been damaged


#140

aquales is played in a similar way.

  1. insert only disk1(system disk) to fdd0, and fdd1 must be empty. RESET and wait for it to load.

  2. when "Disk Not Ready (Drive 1) message appears, goto Menu(F12 or L2), insert disk2(gamedisk or playdisk) to fdd0, disk3(savedisk) to fdd1.

  3. go back to game using menu (F12 or L2) and press a trigger buttons( gamepad button or Z/X on keyboard).

  4. You should see titlescreen now if done correctly.

3-4.


#141

Thanks for reply I did exactly this and still not working. I also downloaded new files of the game, but the same Even the cmd file I did , that was working before, don’t start. The problem only happen on Sol Feace and Aquales But as Its working for you, the problem come from my side, not from an update Thanks anyway


#142

delete /keropi/config

also post log


#143

Tried to delete config file in Keropi, but its the same Here is a log file But in my case Retroarch is not crashing, its just I have a black screen First time I try the log file, so Im not sure if its correct (honnestly I think its not good log file

https://pastebin.com/9rR0HC0x


#144

You had aquales disks inserted in reverse order. after the intro(disk1) inset disk3(savedisk) to fdd0 or drv0(this is 1st drive) then disk2 should be in fdd1 or drv1 (2nd drive).

you had it disk 2 on fdd0 and disk3 on fdd1 which does not work.

did you see the intro and then the “drive not ready message” before swapping disks?


#145

Still not working in this order After I put disk 1, I have the Disk not ready message Then I put Disk 3 and disk 2 Here is my new log :

https://pastebin.com/jEtxdtdk