In the waiting core to be available in updater. I put some binary here. (for win/android/rpi2)


it works very well on android at full frame speed , a little slow in pi2/3 ( better to set 1/2 frame in menu to get fullspeed). and full speed in desktop win/lin.

this core is WIP but pretty usable for now , (although it need some clean-up and better input hook and core options …)

I tried a dozen games (hdf/dim/xdf…), they works fine for the most, except some game(like super mario) where input are not working.


Thanks! nice effort! :slight_smile:

It’s closing on windows though (got the bios, launching MAME roms). Nothing in a log but I’m seeing some badly rendered Japanese text in the background window that closes too fast.

Perhaps a problem caused by the lack of unicode support on windows?

I only tested windows build with wine. And it work for me (i also use mame x68000 bios ). Did you put these file in a folder named keropi in your retroarch system dir ? Anyways i will try it on a real windows device today.

Oh I see. I could make it work now! :smiley:

I did put the bios files into system directly and the core information section was telling me it was OK while it wasn’t working.

I had to move them to a keropi folder and change the info file with:

firmware0_desc = "iplrom.dat (X68000 BIOS)" firmware0_path = "keropi\iplrom.dat" firmware1_desc = "cgrom.dat (X68000 BIOS 2)" firmware1_path = "keropi\cgrom.dat"

All good now.

Some games like akazucha are lacking memory. I can’t find any option to add more and I’m reading the original author notes saying he’s not using the more powerful system as the PSP could not handle it anyway. Is there no way to do that?

For memory you have to boot with humanX and then load switch.x and change memory option i use 2Mo and most game works with

Thanks that worked. :slight_smile:

Of course I had to try to put 12MB and had an error message that forced me to kill the sram.dat. But 4MB is OK, akazucha works now.

It runs great except those numerous sound issues. The need to extract multiple disks and select them with F12 is a bit annoying. Not sure what can be done about that.

Strange i only got sound issue with very few games. (and was little pop sound). for the multiple disk , nothing to do ,:frowning: you can try to find hdf games or create cmd file (but it only handle 2 disks) , so we have to swap disk through F12.

1 Like

OK, I was using “No Wait Mode” ON which allows to fast forward those loading with retroarch turbo, but that’s causing issues with the sound.

I tried 22050 and 48000 modes too but they give strange result: high pitch or huge sound lag easy to test with Akumajou music test mode. Akumajou music only works with X68K internal mode here, 2 other options are silent.

So only NoWait OFF and 44100 seems to work fine minus some clicks here and there (strange notes sometimes too?).

Yes same apply here , and yes core audio rate is set to 44100 (in libretro.c) so other value set from menu will give strange result .

It s maybe possible to change audio rate in core (by changing AV if a change is apply in menu) .

But for now my problem is keyboard polling method that cause some issue like on a French keyboard hitting key ‘8’ will generate 3 inputs => ‘8 ’ ’ ’ ’ _’ (all the key even if key modifier is none) and not just underscore.

Strange, I’m French too but don’t have this problem (just the usual azerty/qwerty crap). Tested that at the x68k command prompt, hotkey button assigned or not, 8 key writes 8.

I noticed the numpad isn’t mapped (some games use it with 4,8,6,2 for directions). But top numbers work for that though. Also the mouse isn’t working.

Strange , but also i has this issue on linux . for mouse you have to toggle (trough F12) joystick to mouse . i tested it on Human68k desktop and works fine , but not in arkanoid ;(

Thanks that worked.

Same problem with arkanoid. You can’t activate the mouse in the game controller setting menu. Also if you use up/down keys in the menu it moves 2 steps at once.

I have the same behaviour with the last mame x68k driver . same for supermario enable to play . BTW i notice in mame screen information that refresh rate is 55.45 maybe i have to change instead of the 60hz

notice: using xvdimode=2 and iplrom30.dat 12mo and 27.9Mhz cpu (xvdi=3 mode segfault (68030 cpu))

Yes it’s less then 60Hz. The hiccups are visible when scrolling like in MAME.

I can select the mouse in Arkanoid with Mame: when you go in the controller menu you move and select with the numpad. Activate the mouse there and it works if everything is done on the Mame side.

No clue about that super mario doujin.

Some additional keys are missing: can’t find _ while ) and = (top range chars after the numbers and before backspace) both write -.

edit: oh yes I could get that 12mb and 27.9Mhz cpu too. I had to remove iplrom.dat from the keropi folder and just keep the iplrom30.dat one or it crashed.

for the _ on my french keyboard(linux) it will throw an 8 and \ and _ (what i said previoulsy) and then print 8_ instead of _. Btw keyboard part need some attention and rewrite , maybe a virtual kbd could be a good option too . i will look at kbd and hz tomorrow.

Amazing work.

Unfortunately is not working on Mac OSX, when opening a game it frezzes retroarch, had to force quit.

Bios is correct (tested with same system folder in Windows).


Etoile princess has problems.

It begins to load if you just insert the system disk, then it stops before the title screen. If you load both system and disk1 it just crashes.

Works fine in MAME.

I ll try it. But not sure i can resolve this.

Sorry for osx freeze. Can you try to give some debug information about the crash? I dont have mac so can’t test myself.

seem to works for me on linux with both disk set. can you provide debug information on crash ?