How to take screenshot in game with overlay?

so my problem i cant take pic of my games with ovelays

there is something special i have to do ? the pic only take the game no with overlay :frowning:

RA does not capture the whole screen. If you enable “Settings->Video->GPU Screenshot”, it will also screenshot shader effects, and the part of the overlay that is directly on top of the game image, but the rest of the overlay will not be captured.

There’s nothing you can do about it. Because of this, I use an external utility to take screenshots.

thanks what kind of utility ?

I’m on Linux with KDE and I use flameshot for this:

https://flameshot.org

I have bound my PrintScr key to this command:

play /usr/share/sounds/freedesktop/stereo/bell.oga > /dev/null 2>&1 && flameshot screen --raw | convert - -quality 92 "$(xdg-user-dir DOCUMENTS)/Screenshots/$(date +"%F-%H-%M-%S-%N").jpg"

which plays a short sound and then makes a JPG screenshot in the “Screenshots” folder of my Documents folder.

I bound Ctrl+PrintScr to this command:

play /usr/share/sounds/freedesktop/stereo/bell.oga > /dev/null 2>&1 && flameshot screen --raw | convert - -quality 100 "$(xdg-user-dir DOCUMENTS)/Screenshots/$(date +"%F-%H-%M-%S-%N").png"

which makes a PNG screenshot.

I did so in KDE’s System Settings:

Workspace->Shortcuts->Custom Shortcuts

In Windows, regular ol’ printscreen should grab it.

Nope. It doesn’t work for stuff that use DirectX, OpenGL, etc, unless you run it in windowed mode.

Really? I was pretty sure I’d grabbed it that way in the past. does that apply with “fullscreen optimization”? Maybe it was running borderless…

It never worked for me in fullscreen. FSO or not. It only works with windowed and borderless windowed. Which makes sense, since it grabs the image data from DWM. In fullscreen, DWM isn’t doing anything and it just grabs black pixels.

thanks for the help i use the old program fraps and works fine screenshot with overlay :slightly_smiling_face:

1 Like

You can also RTSS if you have that (comes with MSI Afterburner.) You can set a screen capture hotkey in the Afterburner settings.

I use print screen in windows all the time. You have to alt+tab away from RA and back again before you do.

I just used print screen to capture this. (An old install using overlays.)

1 Like

I press F8 to take screenshots in RetroArch, alternatively I go to Quick Menu, then choose Take Screenshot. My other method is to press Alt-F1 to take a screenshot using Geforce Experience if I want to get the RetroArch menus included.

Windows print screen works when RetroArch is set to Windowed Fullscreen Mode (Settings-Video-Fullscreen Mode)

you can try by the screenshot by the keyboard?