Immersive overlay

Warning: This is not meant for controlling the game. This is only useful if you have other means of control (gamepad, keyboard), but you would still like to save and load, change shaders and manipulate time without having something on the screen all the time. Update: I made an other one, it has permanent on-screen controls. It’s in the 4th post, scroll down if you’re interested.

Description: The initial screen in completely empty, pressing anywhere brings up the control panel. On the top you can choose between the 3 categories: (floppy, arrows, clock) Pressing anywhere on the bottom half closes the panel.

I only made the controls screen because sometimes retroarch doesn’t respond to my keyboard. It is unsuitable for gaming. I also recommend setting the overlay opacity to about 50%.

Download: … mmerse.rar


  1. Extract the archive anywhere on your device.The 5 files have to be in the same folder, it doesn’t matter where. (1 .cfg file and 4 .png files)
  2. Open retroarch, go to “input options” -> “input overlay” -> browse to where you extracted the files -> press “im.cfg”
  3. Have fun :slight_smile:

That’s a great idea :smiley:

Thanks for sharing it!

I’m glad you like it. :slight_smile: I had been using a more primitive and ugly version of this for quite a time so I thought others might find it useful as well. I am considering making an on-screen gaming oriented overlay, too. Mainly because right now most overlays require you to go through every screen in the same order all the time, instead of letting you choose. Btw, is this the right section for posting overlays?

There is a thread I made back when the overlay system was fairly new: viewtopic.php?f=8&t=239 but there’s nothing wrong with starting a new one. :slight_smile:

I’ve made the new overlay, it’s similar to the one in OP, but with on-screen controls suited for playing. The 3rd screenshot has the explanations written on it. For me the pause button caused retroarch to freeze, but I think there was one time when it resumed so I left it in. (It’s supposed to be a toggle.) The “hide controls” icon is meant to be an eye.

Here’s the download link: … verlay.rar

We’re planning to include your first overlay (the one that starts with a blank screen) with the next release, if that’s cool with you, gosthy. :slight_smile:

Of course I would be OK with that! :smiley: It’s been serving me well for a while, I hope others will like it as well. BTW I see you’ve been trying to get as legal as possible lately. Should I change the invader button to like “MENU” or something?

Great :slight_smile: Just wanted to make sure it was cool before putting it in.

I think the invader will be okay in the overlays, at least. I’ll double-check with Squarepusher, though. All of the overlays have it, so if we’re going to pull it from one, we’d probably be best off pulling it from all of them.

First of all sorry for my bad english. I’m new in this forum and maybe I’m doing something wrong. I’ve tried your overlay with an Huawey Y300 and an Ipega controller. I’ve tapped the screen and your overlay appeared, then I touched the big S but nothing happened. I’ve touched the big L just to check if something was saved but it was not. Was I doing something wrong? Thanks for everything anyway :slight_smile:

Which core did you try? Not all of them support savestates. Can you try it in a few others and see if the issue persists across all of them?

!!! Actually I’ve tried only Mame (the old one). Now I’m out of home so without controller. I’ve tried without controller Snes9x and PCSX rearmed and it seems not working, but honestly is difficult to check saving during the intro of a game. I will check better this evening. In the meanwhile can you please tell me a core that surely support save states? Thanks!!!

snes9x should definitely support them.

[QUOTE=gosthy;8439]Here’s the download link: … verlay.rar[/QUOTE]

I’d like to try this overlay on Android but It;s not recognised by Retroarch.

I extracted the folder to data/user/0/com.retroarch/overlays/misc (needed root for that > thinking that’s the problem) When I browse to Onscreen Overlay > Overlay Preset > misc > ghost overlay in Retroarch, it says “Directory not found.” It doesn’t see the .cfg file in there.

What am I doing wrong?

Try going into settings > directory and changing your overlay directory to somewhere user-writeable on your internal storage. Go over to the online updater and re-fetch the overlays into the new location. Then, put any custom overlays in there and they should be usable.

Yes! That works!

Thanks for the fast reply on a 2 year old thread.


I seem to have lost the “Ghost” overlay. I like it very much, but the download link doesn’t work any more.

Does anyone have a copy of this overlay?

Much appreciated, Colosso.

1 Like

Hi, is this overlay still available in the latest build of RetroArch? I can’t find it and the download link above is broken.

Nevermind, I found it! Had to back out of “gamepads” folder in the Overlay directory and to find the “misc” folder the .cfg is in