Importing ScummVM Games


To be frank, I don’t get it. I have a set of ScummVM games/roms I’d like to import to my RetroArch collection. I’m using the newest version (downloaded today) of RetroArch on Windows 10. So… here is what I CAN do: I can download the ScummVM core and start it (to get into its black/greenish GUI), I can then import games and start them, it’s all working, good.

But that’s not what I want to do with RetroArch, I want to import / add the roms into retroarch itself, like I do with SNES / NES / … roms as well. However, I tried scanning my ScummVM folder a dozen times, RetroArch never recognizes any of my games. Am I missing something or is this simply not working?

Write in a text file a single line containing the “short name” of the scummvm game you want to play (you can see the list of short names here, eg. for “Indiana Jones and the Last Crusade” you should write “indy3” in the file) then rename it with extension .scummvm

If you add this whatever.scummvm file to your library as if it was a ROM it should open with the scummvm core and it will try to load the game corresponding with the short name you wrote inside it.

The only thing is that you would have had to add the game previously in the black/green GUI once, but after that you can open it using the scummvm file.

I opened an issue in libretro-meta about that:

Please follow this documentation, you don’t need to add the game previously.

This works. Thank you.

I got Retroarch running ScummVM with a beautifully working playlist, covers and all, using the method you mention. However, when I went back to the ScummVM core to add another game (also I wanted to shorten the paths on my games) the directory refuses to see my folders and shows only /. I tried typing the path in but it tells me ‘no directory/folders found’ (not sure if its that exactly)

I think it happened after adding the txt files (,scummvm) to my games because the Core was running fine before that. Weirdly, its still running the games I installed. Even stranger is that I deleted one of them before, thinking I would add it again with the new path, but it still runs from my playlist?!!

Sorry to hijack this discussion, but its the only way I have found to ask this question… Please help if you have had this problem…Im stuck.

what’s your platform?