Is there a known fix for PPSPP periodically flashing text symbols?

Once after booting up the core and while running stages in Mega Man Powered Up, about every seven seconds or so, the screen will flicker showing what looks like encrypted text. I’ve found results for similar problems but not this one specifically. So far I’ve been trying different drivers and various core settings but haven’t found a fix yet.

1 Like

I just played it for about 5 minutes with no problems. Have you tried a ROM from a different source?

1 Like

If you provide more details such as Retroarch version and the info of your ROM it will make things easier for more experienced community members to help troubleshoot for you. You could also provide logs. Also what platform you are running Lakka OS/ Retroarch on top of would help, for example Lakka OS for the raspberry Pi has the PPSSPP asset folder and files already included in that build so You don’t have to download and add them to it’s appropriate folder.

I myself have the USA ISO rom for that game on Lakka and it runs fine. Also you could add the DLC for it that unlocks Roll and her various costumes.

Documentation for Logs link https://docs.libretro.com/guides/generating-retroarch-logs/

1 Like

The European ISO seemed to worked perfectly while the two USA ISOs had the same issue. However, I had no issues running any of the ISOs on the standalone version of RetroArch versus the Steam version. Even with the same settings and system files file I couldn’t replicate the flickering that the steam version was producing. I will keep troubleshooting for now

Thanks. I will start putting together a more detailed report

RetroArch 1.9.13 (Git 771585f95d) PPSSPP v1.12.3-80-g59f3d46

I started with a fresh install of the steam version of ReroArch and was able to isolate the cause to running overlays while running the PPSSPP core. I was able to trigger this event on both the Mega Man Powered Up (USA) ISO and (Europe) ISO

Next I will generate and cross-reference logs of the steam and the latest stable build of RetroArch

I have isolated the source further and was able to replicate the flickering text in the standalone stable build 1.9.13 with Mega Man Powered Up (USA)

The conditions required to replicate the flickering text are as follows:

  • (Windows) PPSSPP core (v1.12.3-212-g87d2e16) full screen
  • (Steam) PPSSPP core (v1.12.3-80-g59f3d4b) full screen
  • Display overlay on (running an overlay)
  • Achievements on
  • Leaderboards enabled, or trackers only or leaderboards only
  • And or Verbose Mode On

Temporary fix: Either disable overlays or disable leaderboards and verbose mode

2 Likes