Is there any way to disable the turbo mode?

I try to run <Castlevania:Order of Ecclesia> in Retroarch, and soon I find that you can’t perform a single jump because the turbo function — it just makes your character keep hoping and you can’t play like that at all !

So I checked the input options, and I can’t unbind the turbo switch…

I’m so confused, shouldn’t it be optional? I mean … there are games just don’t work with turbo thing!

So… is there any way to disable the turbo mode or just stop it from working?

I know this is an old topic, but it comes up first on current google searches and it took me a few hours to figure out a workaround while digging around on the forums. Hopefully this will help someone else out and encourage the RetroArch devs to allow users to disable the turbo feature easily in the settings screen.

I bought a USB retro Cadet Premium NES controller (a damn fine game pad, by the way) and loaded up a fresh download of RetroArch, plugged in the controller, configured it, loaded up an NES ROM with the Mesen core and no matter what I did, the B button would trigger the B button’s action when held down, but turbo-repeat the A button’s action as well. Holding down the B button would attack once and continuously jump, basically. I couldn’t disable the turbo in RetroArch or while playing the ROM. Tried lots of combinations of settings and button presses. I should also mention that this controller only showed up in RetroArch as a SNES USB controller. I don’t think any Hyperkin controllers are specifically recognized by RetroArch. Anyway, I did find a work around.

I found this one post here… Added a “Disabled” option inside the “Controller Turbo Speed” setting to disable turbo buttons completely

So just go into the “config/Mesen” folder and open the “Mesen.opt” file and edit the line that says mesen_controllerturbospeed = “Fast” and change it to “Disabled”. Remember to use a capital “D” even though all other settings use the word “disabled” in lowercase. Anyway, I’m not saying all cores have the ability to disable the turbo feature of RetroArch, but for those that do, this should solve the problem. (I believe I found a similar thread with a person wanting to play TurboGrafx-16 games who was in talks with a core developer about implementing a way to disable the turbo button feature in RetroArch. This seems to be a common problem/request with retro game pads.)

I do have newer game pads that work with RetroArch (and I could have used them to play my NES games), but when playing older console games, there’s nothing like the feel of that system’s controller to really bring you into the game.

Note: To unbind a key in RetroArch’s controller configuration menu (like the screenshot in the original post shows), select it and press the “space bar” to wipe it clean.