Issue with gamebatte shader not starting up properly


#1

I forget the name, but I’m using the shader that makes it look like the original green DOT MATRIX Game Boy screen. Looks ridiculously awesome BTW!

Anyway, when I apply the shader, the very dark greenish/black boarder appears. I save the shader preset for the core, so that all titles will start with this shader.

Now, when I exit the core and go back to loading the core, the shader loads the green background, the dot matrix screen, the smear (idk what it’s called) but then it doesn’t load the greenish/black boarder, it’s in pieces almost. So I pause the game by entering the menu, I goto shaders, I simply hit Apply Shader, and then greenish/black boarder reappears as its supposed to.

I have the latest nightlies of both Retroarch & Gamebatte.

Any idea what’s up, and a possible solution? Cause it looks terrible when it doesn’t boot up correctly.

Thanks!


#2

Can you post a screenshot of the problem?


#3

This is when I load gamebatte

This is after I pause retroarch, goto shaders, hit the Apply Shader option twice, and then I get the complete Shader loaded.


#4

do you have integer scaling on, by chance?

if so, does it help to disable it?


#5

I want to say no, and that my aspect is core provided. Because when I set up my retro emus, I use integer scaling. But when I started testing shaders, they were having an issue with integer scaling set.

Could there be other options to check?


#6

I haven’t been able to reproduce this. What kind of GPU do you have and which shader format are you using?


#7

My gpu is a gtx 1060 6gb.

I cannot recall off the top of my head which shader I’m using, nor which video driver. I think the core is using vulkan for the video driver.

Can you please tell me your settings, so I can see if I get the correct results?


#8

I tried it with d3d11/slang and GL/glsl, integer scaling and non-.

I have an AMD GPU.


#9

I tried the same thing you just wrote, but the boarder for me is no longer the dark colored look, it’s just the same color as the main green screen. I guess I’ll stick with this, since now I don’t see artifacts/random pixels of the boarder, when loading a game.