Kid Dracula english translation doesn't work in Nestopia core


I’m trying to run the English translation rom (v1.04 Vice Translations) of Kid Dracula in the latest Nestopia core version but it doesn’t work. I have already added the rom information in NstDataBase.xml with the respective CRC32 and SHA-1 (from the un-headered rom) but it still doesn’t run. Is it a bug in the Nestopia core? It worked perfectly for me in the past when adding the rom information in the XML (Nestopia core).


In fact, this happens not only with Kid Dracula, but with other Japanese games. In these cases I solve using the Core “fceumm_libretro.dll” because some Japanese games only work on this Core.

It’s an issue with the mapper in konami titles - it happens with all the translations of their games in Nestopia. There is a way around it but it’s a bit of a mess and involves changing CRC’s in the internal database. Alternatively you can use a very old version of Nestopia and it will work (i can’t remember which version the problem appeared in though).

Realistically though, you’re much better off using another core like Messen which is a better emulator anyway.