Kronos very poor compatibility and peformance

Just thought I’d ask about this core to see if I’m doing something wrong. I am able to run just about any game with the Saturn Beetle core at full speed and I was excited to try the new Kronos core which has given me nothing but issues on now two Windows 7 computers. I’ve tried several games and I can get Daytona, Panzer Dragoon, and Virtua Racing to run, but I cant get Bug!, Panzer Dragoon II, Sega Rally, Gungriffon, to boot at all. Even the games that boot don’t run particularly well no matter the resolution settings. I thought Kronos was supposed to be easier for older CPUs vs. the Mednafen core and I’ve seen nobody else complain about performance.

My computer specs are:

Computer 1: Core i5 2500 GTX 950 8GB RAM

Computer 2: Core i5 2320 GTX 750 4GB RAM

1 Like

nobody’s complained about it because it’s only been available for like a day…

We’re still actively working on it, so, while we appreciate the report, give it a little more time before forming any lasting impressions.

1 Like

Please don’t think that I’m complaining. You guys know that I appreciate all that you do. I was honestly wondering if there was something amiss with my setup since Mednafen runs so much better which is technically supposed to be harder to run. I can wait. Keep up the amazing work!

That’s what you are doing though.

About performances, i’m able to run a few games at full speed on with integrated gpu, which is definitely impossible on beetle-saturn (30fps at most). And my i7 2600 with a GTX 960 (so a really close configuration to yours) is performing marvelously on every game, while using half of the cpu ressources beetle-saturn is using.

Apart from Bug! (boot but black screen after movie introduction, seems like a known issue though : , sorry it’s french), seems like all of those games boot and are playable for me (redump releases).

AFAIK, retro buildbot had some issues where it would build at random commits, not sure it was solved so if you could tell me what commit you are using to make sure you have the latest will all fixes…

1 Like

You’ll have to forgive me, but I don’t know what you mean by commit.

when you load the core, it should show the commit label after the core’s name in the bottom-left, after the core’s name and version, e.g. CoreName 0.5.5 c1de0e8

c1de0e8 is the commit label in this case.

1 Like

Ah I see. It’s


I just did a Core update and now my commit is:


Panzer Dragoon 2 still doesn’t boot. Powerslave boots and is mostly playable until it locks up. Bug Too! actually does boot and is playable for the most part until it locked up my computer and crashed my sound driver fixable only by a restart of the OS. Burning Rangers boots and locks up going into the game after meun selections have been made. Sega Rally does not boot nor does it give a black screen. It just sits on my desktop until I toggle the menu bacl to close the core. Radiant Silvergun plays extremely well as long as hard gpu sync frames is set to 1 or GPU hard sync is off. Thundeforce V boots and runs ok until you shoot and then the frames just to below playable territory. Daytona USA is now 99% smooth all the way through. Sega Ages vol. 1 does not boot with just a black screen. The same go for Gungriffon. Virtua Racing runs better than it does on an actual Saturn but the music ignores any ques that happen when passing through a checkpoint and just cycles through the entire music library throughout the game. Again, not complaining, just thought I would provide some feedback on my results especially since it seems that nonone else is.

1 Like

You are using the latest version, seems like the “no-boot” issue is specific to the isos you are using then, i tried a few of them to see if i could reproduce it :

  • For “Sega Ages Volume 1” and “Sega Rally”, i have the USA versions crashing, all others ran fine
  • I have all versions of “Panzer Dragoon II Zwei” working
  • For “Gungriffon”, i have a black screen after game over for the USA version, Japan seems to have a black screen before the game start

If you want to make reports, make them accurate, with iso version, i can’t spend my life trying all versions of a game.

Also, i don’t know which “sync” options are safe with the kronos core. With the core having its rendering part running in an “asynchronous way”, i wouldn’t recommend to use any of them atm (they are most likely the causes of most of your issues), that’s basically like breaking legs of someone then telling him to run a marathon… We’ll try to fix those sync issues at a later date, that’s low priority atm.

My bad, actually all games boot, i forgot clrmamepro deleted part of those isos when i ran it some time ago.

It should be obvious, but make sure you have the bios at retroarch_system/kronos/saturn_bios.bin…

1 Like

I can’t start PD Zwei either, tried with three different isos. The one I use with other emus (which kronos doesn’t seem to like) is the one that was [edited to follow rules]. Castlevania SotN also won’t boot. These run well in all the other emulators I use (Beetle Saturn, SSF, yabasanshiro standalone). Regardless, kronos is progressing very nicely, congratulations : )

[editor’s note: don’t mention sites that distribute illicit ROMs. As far as we’re concerned you dump your own legally owned games in accordance with your local laws and statutes]

bios… i just confirmed the issue, i’m removing the “no bios” fallback to HLE bios from the core.

Edit : Also, don’t mention romsites, thanks…

1 Like

Sorry about that, guys. I only mentioned the website because I misunderstood BarbuDreadMon’s request on iso versions. Also I didn’t know kronos needed its own system folder, it’s not that obvious ; )

edit: yeah, with the bios in its place, things work

Depends if you are new on libretro or not :

  • emulators generally needs bioses and/or other support files
  • information about the exact files needed are in the info file

I guess having a way to tell the user through the ui would be nice though, with the information in the info file and retroarch reading it, it should be possible for retroarch to check if the needed file are present and tell something in the ui if they are missing ?

Thanks for this core.

There’s plans to add the dynarec from Yaba Sansiro?

Not new. In fact, I fancy myself as a power user : )

I do not have a kronos info file though (guess it was released together with 1.7.5? I’m still using 1.7.4). I haven’t actually seen a lot of information about the core around, thought it was because of its young age. Maybe I wasn’t looking in the right places.

Anyway, merci beaucoup!

You can update your info files through the online updater any time, so you never have to feel behind :slight_smile:


It would need some testing to see if it’s worth it. As far as we know, kronos’s cached SH2 interpreter is offering the same performance boost over the original yabause interpreter than the YabaSanshiro dynarec (about -40% cpu usage). Also, dynarecs are nice except they are not cross-platform…

Well that’s the first time I’ve ever needed to give a core it’s own folder in the system folder but that did the trick. Panzer Dragoon 2 not only boots but runs extremely well until it locked up on me after I beat the 3rd stage boss. Burning Rangers boots and runs great as well. Sega Rally acts like it boots but freezes at the Sega copyright logo. Gungriffon boots and has patches of slowdown and sound stuttering…then it locked up on me. A.M.O.K. runs smooth as silk. Thunderforce V still runs badly whenever you shoot. Daytona still runs good as always. Bug! now boots but crashes as expected after the intro video. Powerslave now runs excellent and looks really nice in twice the resolution which is very exciting, for me at least. I might try a different ISO for Sega Rally since it seems to be the only game so far that I can’t get to boot that doesn’t have known issues. I assume the lock ups are just because the emulator is in alpha.

1 Like

fbalpha, reicast, mame, mupen, dolphin, … all expect their own folder in system_directory, however most of them have fallbacks paths for their bioses. I added fallback paths for bios a few minutes ago, now it will check in the system root directory too, it will even fallback to beetle saturn bioses if available.

And yes, the emulator is not bug free (none is, i have seen my share of issues in beetle saturn while looking at it over the past few days), however it has pretty solid compatibility and performances if you set it right (your Thunderforce V issue is pretty weird, it’s running well here even at higher resolutions). Thanks for the Panzer Dragoon 2 3rd boss report.