Lakka 3.4 Rpi3 aarch64 Duckstation won't start

Hi everyone,

Just testing out the new 3.4 aarch64 release on my Rpi3. Everything works great apart from the Duckstation core which will not start. I have tested with all my games and the behaviour is the same. Swanstation working fine, PCSX ReArmed and Beetle PSX running as expected.

I have generated a log but can’t work out how to upload it here.

Any ideas?


you can copy/paste the log somewhere like and then post a link here.

1 Like


Thanks so much.

Here is the log for anyone who might be interested in taking a look:

Thanks again!

This seems to be the problem, but I’m not sure how you would fix it:

[ERROR] [Video]: Cannot open video driver ... Exiting ...
[ERROR] Fatal error received in: "init_video()"

Thanks for having a look. I’ll keep playing around with stuff to eliminate any errors I might have made. Duckstation works great in windows using the same games and bios etc. so I know they’re all good.

Anyone else run into this?

Thanks again.

It’s because it’s trying to use the OpenGL renderer and the RPi3 only supports the software renderer. SwanStation is patched for this in Lakka but DuckStation is not.

Edit the DuckStation opt file manually so that it uses the software renderer:

duckstation_GPU.Renderer = "Software"

I should note that I have tried to use the DuckStation core on my RPi3 on RPi OS aarch64 and it does not work (not because of this, it segfaults), but it might work in Lakka.


Fantastic. I’ll give it a try ̶t̶o̶m̶o̶r̶r̶o̶w̶ right now and let you know how I get on.

This worked perfectly, thanks so much! I am genuinely astonished by the knowledge and goodwill shown by members of this forum.

Thankyou @metchebe and @hunterk.