Libretro PPA for Ubuntu


#61

retroarch-joypad-autoconfig deb package will be provided because currently you can’t update autoconfig with the online updater ?


#62

Hi, I’m running Xubuntu 16.04 and when I start RetroArch in a terminal, the following message displays: “org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files”. Is Gnome required to run RA? Thanks.


#63

No, gnome isn’t required. That may be the screensaver suppression complaining but it’s probably not what’s keeping it from loading.


#64

Installed Lubuntu overnight last night. This should work with all ubuntu flavors right? I have an older machine (2.4 ghz dual core, 4 gigs of ram) that i want to set up as kind of an emulation station. Not at home to try this but this has my interest.


#65

Yeah, should be fine.


#66

I did a bit of digging, and after changing the menu_driver to rgui and video_driver to sdl2, I followed this, adding two rules for event* and mouse*. RA still won’t run, however. –verbose returns the following:

RetroArch [INFO] :: === Build =======================================
Capabilities: MMX MMXEXT SSE1 SSE2 SSE3 SSSE3 SSE4 SSE4.2 AVX AES 
Built: Jul 18 2016
RetroArch [INFO] :: Version: 1.3.6
RetroArch [INFO] :: =================================================
RetroArch [INFO] :: Looking for config in: "/home/name/.config/retroarch/retroarch.cfg".
RetroArch [WARN] :: SYSTEM DIR is empty, assume CONTENT DIR
RetroArch [INFO] :: Config: loading config from: /home/name/.config/retroarch/retroarch.cfg.
RetroArch [INFO] :: Resetting undo buffers.
RetroArch [INFO] :: Environ SET_PIXEL_FORMAT: RGB565.
RetroArch [INFO] :: Version of libretro API: 1
RetroArch [INFO] :: Compiled against API: 1
RetroArch [INFO] :: Set audio input rate to: 29975.00 Hz.
RetroArch [INFO] :: Video @ 960x720
RetroArch [INFO] :: [SDL]: Available renderers (change with $SDL_RENDER_DRIVER):
RetroArch [INFO] ::     opengl
RetroArch [INFO] ::     opengles2
RetroArch [INFO] ::     software
RetroArch [INFO] :: [SDL]: Available displays:
RetroArch [INFO] ::     Display #0 mode: 1600x900@59hz.
RetroArch [INFO] :: [SDL]: Creating window @ 960x720
RetroArch [INFO] :: Using font rendering backend: freetype.
RetroArch [INFO] :: Suspending screensaver (X11).
RetroArch [INFO] :: Graphics driver did not initialize an input driver. Attempting to pick a suitable driver.
RetroArch [INFO] :: [udev] Adding device /dev/input/event3 as type ID_INPUT_KEYBOARD.
RetroArch [INFO] :: [udev] Adding device /dev/input/event6 as type ID_INPUT_MOUSE.
RetroArch [INFO] :: [udev] Adding device /dev/input/mouse1 as type ID_INPUT_MOUSE.
Protocol error: bad 3 (Window); Sequence Number 11
 Opcode (20, 0) = GetProperty
 Bad resource 0 (0x0)
 at -e line 15.
RetroArch [INFO] :: [udev] Adding device /dev/input/event5 as type ID_INPUT_TOUCHPAD.
RetroArch [INFO] :: [udev] Adding device /dev/input/mouse0 as type ID_INPUT_TOUCHPAD.
RetroArch [ERROR] :: [udev] Failed to open device: /dev/input/mouse0 (Inappropriate ioctl for device).
RetroArch [INFO] :: Found joypad driver: "udev".
RetroArch [INFO] :: ALSA: Using signed 16-bit format.
RetroArch [INFO] :: ALSA: Period size: 768 frames
RetroArch [INFO] :: ALSA: Buffer size: 3072 frames
RetroArch [INFO] :: ALSA: Can pause: yes.
RetroArch [INFO] :: SRAM will not be saved.
RetroArch [INFO] :: null: [/home/name/.config/retroarch/content_history.lpl].

I’m using a laptop with both a touchpad and a nipple mouse. I’m not quite sure where to go from here, and was wondering if you had any ideas. Sorry if this is the wrong thread. Thanks!


#67

Any ETA when there will be builds for 16.10?


#68

There is a package for Ubuntu 16.10. Otherwise, you can try use AppImage and you can get binary delta updates.


#69

So, no current builds for Ubuntu 16.10? I thought that the ppa might keep Retroarch more current than what is in the Ubuntu-repos. I will have a look at the AppImage, even though I’d prefer the ppa.


#70

Use the libretro testing PPA, there are builds there. The package in the ubuntu repo is 1.3.6, it’s the same of the stable PPA…


#71

Thanks a lot, I will have a look.


#72

I’m getting an older, version 0.9.38 build of the PSX core from the Ubuntu PPA. Is there any information on when we’re getting version 0.9.39? I’m interested because the higher version (that is available on Windows) let’s me use the “Internal GPU Resolution” setting and I’d want to do the same in Linux. Thanks in advance!


#73

Are you using the stable or testing ppa? If stable, try updating to the testing one and it should use the same codebase as the Windows nightlies.


#74

GLupeN64 added in the testing PPA :wink:


#75

First of all thanks for the PPA. Are you going to add UAE to the test PPA? Having an Amiga emulator as well would be great. Thank you


#76

I could, but FS-UAE makefile is truly messed. I can’t build it.


#77

I installed Retroarch this way but it has no sound. All other emulators work fine on my computer but libretro cores. Is there a way to fix this?


#78

You can try going into settings > driver and changing your audio driver to something else.


#79

ugh, again this issue? It’s PulseAudio by default, it should be working. Try Alsa.

What Ubuntu version are you using?


#80

I’m using the most recent build of Lubuntu and I tried all of the available settings and nothing worked. Everything else works fine. Hell, even the Retropie GUI has sound, just not the cores