Load & Download A Core On Retro Arch Using Linux Mint

I’ve tried 3 times to download a core by going to Load Core> Download a Core. ‘Download a Core’ doesn’t exist in the interface.

Gaming is new to me and I don’t understand. I was able to find a way to add Download a Core however, there are no entries to display.

I’m reading here for help: https://docs.libretro.com/guides/download-cores/

What am I missing?

How did you install again? PPA? Is this an x86/_64 device or ARM linux?

A PPA on a x86_64 bit desktop running Linux Mint 21.

Hmm, the core updater (or ‘download a core’ routine) should be populated with a bunch of cores for x86_64, namely all of these: http://buildbot.libretro.com/nightly/linux/x86_64/latest/

Sadly it’s not being populated when I select Download a Core. Is there a way to add all of those in the link you provided manually?

It’s not the absolute latest versions of the cores, but you can take this stable core snapshot: http://buildbot.libretro.com/stable/1.15.0/linux/x86_64/RetroArch_cores.7z unzip it and drop all of the cores into your ‘cores’ directory, which you can find the path of by going to settings > directory.

Before installing or updating a core, you have to go in the Main Menu to, Online Update - Update Core Info Files, otherwise nothing will be listed.

  • brief note: The help document is out of date, with the ppa you don’t need to install the cores from the repository, you do it from the interface like everyone else.

I downloaded all of the RetroArch_cores. Then unzipped and dropped all of the cores into the cores directory. So that’s done.

I did exactly as you said to do going to from the Main Menu Online Updater> Update Core Info Files> Tried it 3 times.

Upon doing so I see a message at the bottom of the window saying “fetching core list” Then when I select download a core it says no entries to display.

Thanks for telling me that the help document is out of date. :smile:

Yes, sorry for the outdatedness, it’s something that escapes.

“Fetching core list” is the message that appears when you select the “Core download” option.

The “Update Core Info Files” option is a little further down.

You must update everything.

A post was split to a new topic: Mystery problem

Ok, I found Update Core Info Files and pressed Enter. Upon doing so I saw "Downloading info zip.

When I follow the path from the Main Menu> Load Core> Retro Arch-Linux-x86_64.AppImage.home> Fetching Core List, there are No Entries to Display.

How would I get the cores to load?

If you’re using the AppImage with the portable home directory intact, it should have all of the assets and info files bundled in already. If you don’t use the portable home directory, it will all point back to your ~/.config/retroarch directory and you’ll need to fetch everything from the online updater (info, assets, shaders, etc.).

I’m using the AppImage so that’s done. I’ve tried going through the interface and used the online update as well.

To be clear I created a BIOS directory, a ROM directory and downloaded and created a directory for the RetroArch_cores that you linked for me.

BTW, I changed the API to ozone which is much easier to work with.

Is there a chance that the ROM is a bad dump or the cores are a bad dump too?

How do I launch the pacman game?

But, aren’t you using the PPA?

@Alexzee you have a mess of versions, in the other post you say you installed snap, flatpak, ppa and you use appimage?
Linux is a demanding system, you have to be careful.

Each way of installation has a different configuration folder:

  • Ubuntu’s PPA (and derivatives) has it in HOME/.config/retroarch
  • Snap inside the Snap folder in Home
  • Flatpak inside the hidden .var folder in Home
  • AppImage creates a Home right next to the executable, but you can also delete that folder and use the default PPA folder.

They all work the same, the one you choose depends on your taste. But if you are just starting out I recommend the PPA, everything is automatic. Appimage requires manual update, and create the shortcut manually.

Before doing anything else, uninstall RetroArch from Snap and Flatpak, open the terminal and paste this:
sudo snap remove retroarch; flatpak remove retroarch -y

Open RetroArch, whichever you choose to use.
Go to “Main Menu » Configuration File”.
Select Reset to Defaults.
Restart Retroarch.

The core and core information files are stored in the same place, you can see the directories in Settings " Directory.
This is how Appimage and the PPA would look like respectively.

Now it should work normally, but… You haven’t changed the administrative permissions of Home? Have you? :roll_eyes:

1 Like

Yes, I installed the PPA. After running the command that you posted with root privileges retroarch was not found nor installed.

From the Main Menu I went to the config file and selected Reset to Defaults and then restarted Retro Arch like you said to do and…upon doing so I have unreadable text. See the screenshot.

No, I have not changed the admin permissions of Home:-

Are you sure you are using PPA? You can see this in the previous message:

That’s Appimage.

You are missing all the files.
You probably deleted the Appimage home folder, and it will look for the repository folder, which does not exist either.

I created a directory for the Retro Arch- Linux- x86_64.AppImage: Alex: cd Cores Alex: ls RetroArch_cores.7z RetroArch-Linux-x86_64 Alex: cd RetroArch-Linux-x86_64 Alex: ls RetroArch-Linux-x86_64.AppImage.home Alex:

The libretro PPA is present in the Software Sources MGR:

Should I delete the “Cores” directory, remove the PPA and start over with a fresh installation of the PPA?

Sorry for any confusion, I’m really trying to do the right thing here.

Don’t worry, that’s what this forum is for. :slight_smile:

RetroArch comes pre-configured and everything will work fine. You only need to change two directories, “File Browser” which is where you save the games and “System/BIOS”, for the system files. You can also use the default folder for the bios, it’s a matter of taste.

Let’s focus on the PPA. delete the entire Appimage folder, and also delete the RetroArch configuration folder, under"HOME/.config/retroarch".

Open RetroArch and it will appear indivisible, you have to update the Assets to be able to see it well. Close it and run this in the terminal. This mini scrip installs the decompressor, download and unzip the assents in the corresponding folder.

sudo apt install p7zip-full -y; cd ~/.config/retroarch/assets/; wget https://buildbot.libretro.com/assets/frontend/assets.zip; 7z x assets.zip -y; ; rm assets.zip

At startup, it should look good.

@hunterk I installed stable to test Stable, (purge the ppa testing and delete the configuration folder). When I start RetrArch, it does not have the Assets, is this normal?
I don’t remember well, I haven’t installed it for a long time, but I think it has everything normal at startup.

No, it doesn’t come with assets. There’s no way to do that, unfortunately, since they need live in the user’s home directory and the package manager isn’t allowed to write there.

This is why the AppImage comes with the portable home directory.

1 Like