MAME 2014 core auto save-load state won't work, because it can't create new folders


#1

Hey, I was just moving my MAME setups from standalone to RetroArch, and I encountered a problem where cfg, nvram, and other files wouldn’t be saved in the save folder. Then, lurking around the board, I wound an explanation: for some reason, it can’t create the folders needed, so the files can’t be written. But after creating those folders manually ({savefiles]/MAME 2014/mame2014/cfg, for example), the files could be created and modified normally. This fixed the problem.

However, the core option of auto save-load save states depends on creating a new folder for each game inside the states folder ({savefiles]/MAME 2014/mame2014/states/{gamename}), so it doesn’t work unless I manually create a folder with the name of EACH game (which, as you know, it’s very inconvenient for a MAME romset).

Is there a way to actually fix this and let the core create all the folders it needs? Is it a problem with my configuration? Or is it a bug within the core that hasn’t been (or won’t be) addressed?

What I’ve already tried.

  • Update to latest nightly and update cores.
  • Run RetroArch with administrator right
  • Manually sanitizing my savefolder path on the retroarch.cfg (end it with an \ at the end, like [B]d:\retroarch\savefiles[/B] instead of just d:\retroarch\savefiles. This was suggested on an old thread of this forum, but it didn’t work for me.

Any ideas?

Thanks in advance.


[Request for Approval] Create doc page for MAME 2014 core
#2

I’m pretty sure mame2003 can create its own directories. I guess the same capability would have to be added into mame2014


#3

So it is a problem with the core. That clears it up, thanks for your quick answer :slight_smile: I guess there’s nothing for me to do besides wait for an update.


#4

[QUOTE=spinningacorn;48269]So it is a problem with the core. That clears it up, thanks for your quick answer :slight_smile: I guess there’s nothing for me to do besides wait for an update.[/QUOTE]

You could file an issue in the github bugtracker for the MAME 2014 core if you feel comfortable writing up a summary of this thread.

I’m not much of a coder, but it might be a very easy change and someone will be able to help quickly (since it’s been done with another MAME core). Or it could be a very hard change and may not happen for a while. :slight_smile:


#5

it creates the folder for me just fine… IIRC (it was 2014 bear with me) it works when the savefile_dir contains a trailing slash (or viceversa)


#6

[QUOTE=Radius;48352]it creates the folder for me just fine… IIRC (it was 2014 bear with me) it works when the savefile_dir contains a trailing slash (or viceversa)[/QUOTE] Thanks for your response! I actually found a post of your explaining the same thing in a previous thread (I did lurk before asking). I addressed this on my first post:

[QUOTE=spinningacorn;48219] What I’ve already tried.

  • Manually sanitizing my savefolder path on the retroarch.cfg (end it with an \ at the end, like [B]d:\retroarch\savefiles[/B] instead of just d:\retroarch\savefiles. This was suggested on an old thread of this forum, but it didn’t work for me.[/QUOTE]

I tried it, but it didn’t work for me :frowning:

Still, even if it this was the solution, shouldn’t the core be able to figure out the directory anyway? Considering that setting the save folder through GUI results in a path without a “” at the end.


#7

I know I should report it there if it were a bug, but I really wanted to make sure I wasn’t making any mistakes on my side before assuming it’s a bug :stuck_out_tongue:


#8

AH! Ok, now I see why Radius says it works but it doesn’t for me. I’m sorry for asuming there was something wrong with the core, I figured it out the problem is on my end. I checked on a different setup (Windows 7), and the folders got created with no problem. The problem occurs only on my Windows 10 setup. Most likely, it has to do with the program’s permission on WIndows.

I still don’t know how to fix it there though. I already run RetroArch with (supposedly) full administrator rights. I’ll try to fix this and share the solution once I figure it out.


#9

I just wanted to add that I don’t have this problem with mame2003, that one works perfectly. It’s only mame2014 that won’t create folders by itself.


#10

Hello, I have the same problem with the last core of MAME. They don’t want to fix it? I need a save for my score :slight_smile: